Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
432edf7a
Commit
432edf7a
authored
7 years ago
by
Shiz ...
Browse files
Options
Downloads
Patches
Plain Diff
testing/julia: fix PaX and rpath issues, add missed files to -dbg
parent
2437d87e
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/julia/0005-fix-rpath-issues.patch
+11
-0
11 additions, 0 deletions
testing/julia/0005-fix-rpath-issues.patch
testing/julia/APKBUILD
+7
-1
7 additions, 1 deletion
testing/julia/APKBUILD
with
18 additions
and
1 deletion
testing/julia/0005-fix-rpath-issues.patch
0 → 100644
+
11
−
0
View file @
432edf7a
--- a/Make.inc
+++ b/Make.inc
@@ -873,7 +873,7 @@
RPATH_ESCAPED_ORIGIN := $(RPATH_ORIGIN)
RPATH_LIB := -Wl,-rpath,'@loader_path/' -Wl,-rpath,'@loader_path/julia/'
else
- RPATH := -Wl,-rpath,'$$ORIGIN/$(build_libdir_rel)' -Wl,-rpath-link,$(build_shlibdir) -Wl,-z,origin
+ RPATH := -Wl,-rpath,'$$ORIGIN/$(build_libdir_rel)' -Wl,-rpath,'$$ORIGIN/$(build_private_libdir_rel)' -Wl,-rpath-link,$(build_shlibdir) -Wl,-z,origin
RPATH_ORIGIN := -Wl,-rpath,'$$ORIGIN' -Wl,-z,origin
RPATH_ESCAPED_ORIGIN := -Wl,-rpath,'\$$\$$ORIGIN' -Wl,-z,origin
RPATH_LIB := -Wl,-rpath,'$$ORIGIN' -Wl,-rpath,'$$ORIGIN/julia' -Wl,-z,origin
This diff is collapsed.
Click to expand it.
testing/julia/APKBUILD
+
7
−
1
View file @
432edf7a
...
...
@@ -5,7 +5,7 @@ pkgver=0.5.2
# Keep in sync with deps/libuv.version.
_libuv_ver
=
8d5131b6c1595920dd30644cd1435b4f344b46c8
_llvm_ver
=
3.9
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"A high-level, high-performance dynamic language for technical computing"
url
=
"http://julialang.org"
# x86: no libunwind package
...
...
@@ -55,6 +55,7 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$
0002-verbose-build.patch
0003-no-clean-docs.patch
0004-remove-sysctl.h.patch
0005-fix-rpath-issues.patch
0008-ldconfig-compat.patch
fix-or-disable-broken-tests.patch
"
...
...
@@ -144,16 +145,20 @@ package() {
make
install
install
-D
"
$srcdir
"
/find-syslibs
"
$pkgdir
"
/usr/share/julia/find-syslibs
# re-apply lost PaX markings
paxmark m
"
$pkgdir
"
/usr/bin/julia
"
$pkgdir
"
/usr/bin/julia-debug
}
dbg
()
{
pkgdesc
=
"
$pkgdesc
(debug build)"
replaces
=
"
$pkgname
-debug"
default_dbg
install
-d
"
$subpkgdir
"
/usr/bin
mv
"
$pkgdir
"
/usr/bin/
*
-debug
"
$subpkgdir
"
/usr/bin/
install
-d
"
$subpkgdir
"
/usr/lib/julia
mv
"
$pkgdir
"
/usr/lib/
*
-debug
.
*
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/julia/
*
-debug
.
*
"
$subpkgdir
"
/usr/lib/julia/
}
...
...
@@ -164,5 +169,6 @@ c53513a5aea84405bf302b084a23f24f54148aac90a2bd666219ce14879723baab959942934d0d80
6530709d5cd58970b5868a6a536727df6839b3aedfe81c67d4e5b37cf840803a33027eed338b47816810b9ae1119470acd097806e90a41cd59f8d1fcb0843663 0002-verbose-build.patch
66add07137c3baafba86aea1469ee2cf669f3fa4c01195c04c7a3f9e1b4a85dee020bef315919efa6261b675049bc251aa9fc1878ae7f7929baed5084eb697d7 0003-no-clean-docs.patch
6c111ccdd12af5b00fdf0b7cc8fba11980fceccf7c246b40e791cd1be8e39cd75b8c290c65ebd9b4add60fc242261e17e94807736fce6a96733e9bf18182b489 0004-remove-sysctl.h.patch
9875b3cdc49bcc2812ea52b2e25836ba22058dbad94287c9aa7c4e4ee48b7819655588a08d49cb9a3c73431ff6969b3b7eb140fc96dc5b0d64777c3027e06538 0005-fix-rpath-issues.patch
a66526aee8745875b254f0d27db78b10e76cd8489f4601c77b82674a31ee7a0cf417af8b24a520e069a464303ad7f0077b75543e197eaba48a75b960c9f81a05 0008-ldconfig-compat.patch
1d128441bb3e15defa2b23c8d68255fe15320060ac7203ebf7d3573e9e8c0120ebf49b2256f022fdddcc816691c6271f35a27d36b03cbe203734b9f902417ca9 fix-or-disable-broken-tests.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment