Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
06a7fac1
Commit
06a7fac1
authored
9 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/freeswitch: fix empty voicemail password
Upstream issue:
https://freeswitch.org/jira/browse/FS-8131
parent
c2d8feb8
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
+28
-0
28 additions, 0 deletions
...S-8131-mod_voicemail-fix-disallowed-empty-password-.patch
main/freeswitch/APKBUILD
+8
-4
8 additions, 4 deletions
main/freeswitch/APKBUILD
with
36 additions
and
4 deletions
main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
0 → 100644
+
28
−
0
View file @
06a7fac1
From 7aba5d52ee609e63ede7e76ab955179e9c61244d Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 7 Sep 2015 16:23:56 +0200
Subject: [PATCH] FS-8131: [mod_voicemail] fix disallowed empty password set
Prevent users to change password to an empty password when
allow-empty-password-auth is set to true.
---
src/mod/applications/mod_voicemail/mod_voicemail.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/mod/applications/mod_voicemail/mod_voicemail.c b/src/mod/applications/mod_voicemail/mod_voicemail.c
index da6180a..6300211 100644
--- a/src/mod/applications/mod_voicemail/mod_voicemail.c
+++ b/src/mod/applications/mod_voicemail/mod_voicemail.c
@@ -2305,6 +2305,9 @@
static void voicemail_check_main(switch_core_session_t *session, vm_profile_t *p
switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Domain", domain_name);
switch_channel_event_set_data(channel, params);
+ if (zstr(buf) && !profile->allow_empty_password_auth) {
+ fail = 1;
+ }
if (switch_xml_locate_user("id", myid, domain_name, switch_channel_get_variable(channel, "network_addr"),
&xx_domain_root, &xx_domain, &xx_user, NULL, params) == SWITCH_STATUS_SUCCESS) {
switch_xml_t x_result;
--
2.5.1
This diff is collapsed.
Click to expand it.
main/freeswitch/APKBUILD
+
8
−
4
View file @
06a7fac1
...
@@ -3,7 +3,7 @@
...
@@ -3,7 +3,7 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname
=
freeswitch
pkgname
=
freeswitch
pkgver
=
1.4.20
pkgver
=
1.4.20
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"A communications platform written in C from the ground up"
pkgdesc
=
"A communications platform written in C from the ground up"
url
=
"http://www.freeswitch.org"
url
=
"http://www.freeswitch.org"
arch
=
"all"
arch
=
"all"
...
@@ -71,6 +71,7 @@ source="http://files.freeswitch.org/$pkgname-$pkgver.tar.xz
...
@@ -71,6 +71,7 @@ source="http://files.freeswitch.org/$pkgname-$pkgver.tar.xz
system-lame.patch
system-lame.patch
0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
fix-voicemail-greet-reset.patch
fix-voicemail-greet-reset.patch
0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
"
"
_builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
_builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
@@ -225,7 +226,8 @@ c608cca8ad773acebf201f581438c7e7 freeswitch.confd
...
@@ -225,7 +226,8 @@ c608cca8ad773acebf201f581438c7e7 freeswitch.confd
4cd4923463c89bed053e6295b5a4ec40 freeswitch-mod_shout-textrels.patch
4cd4923463c89bed053e6295b5a4ec40 freeswitch-mod_shout-textrels.patch
6a6c4aba80e99c236ef712b17f3cdd01 system-lame.patch
6a6c4aba80e99c236ef712b17f3cdd01 system-lame.patch
0d9dc1f09b6c150622bc59cdba86b89c 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
0d9dc1f09b6c150622bc59cdba86b89c 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
ca7ef52c092f66b06dbf76dce2d05eb3 fix-voicemail-greet-reset.patch"
ca7ef52c092f66b06dbf76dce2d05eb3 fix-voicemail-greet-reset.patch
e775523c5f530e7ec7a72507637d6c2d 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
sha256sums
=
"46bb7e7f83dd616f268085c7e36fd45b48c3f02821dbea110211f0e10da16b09 freeswitch-1.4.20.tar.xz
sha256sums
=
"46bb7e7f83dd616f268085c7e36fd45b48c3f02821dbea110211f0e10da16b09 freeswitch-1.4.20.tar.xz
816fb2d4baab09e2f51a7c1be75bc9e03ed09d4cf3c2cd03c183f433bb9b565f freeswitch-json-c-0.9.tar.gz
816fb2d4baab09e2f51a7c1be75bc9e03ed09d4cf3c2cd03c183f433bb9b565f freeswitch-json-c-0.9.tar.gz
678c3860fd539402b5d1699b921239072af6acb4e72dc4720494112807cae411 freeswitch-flite-2.0.0-release.tar.bz2
678c3860fd539402b5d1699b921239072af6acb4e72dc4720494112807cae411 freeswitch-flite-2.0.0-release.tar.bz2
...
@@ -240,7 +242,8 @@ db0d3c252b5664ecb071bcf6868eff77c85dd7943a63fcfcac7e19db6a0ff61f libshout-disab
...
@@ -240,7 +242,8 @@ db0d3c252b5664ecb071bcf6868eff77c85dd7943a63fcfcac7e19db6a0ff61f libshout-disab
be1009327de615f04956ba0b0f44183f31c263e380af8027f94b976a84bcb09a freeswitch-mod_shout-textrels.patch
be1009327de615f04956ba0b0f44183f31c263e380af8027f94b976a84bcb09a freeswitch-mod_shout-textrels.patch
11b107ca8632bb9c8fcb2aedfcfb421af24929aace4f56c34d4e701eb410e190 system-lame.patch
11b107ca8632bb9c8fcb2aedfcfb421af24929aace4f56c34d4e701eb410e190 system-lame.patch
1e3c67da8c17130d872213c718b8113f7cb08e67e166a91e2507facd8cd15b58 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
1e3c67da8c17130d872213c718b8113f7cb08e67e166a91e2507facd8cd15b58 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
5581489ce522d8c46f9bfccb8ab2c581cc4cd6c2da9a8d9ed80ebfe8cbd59b70 fix-voicemail-greet-reset.patch"
5581489ce522d8c46f9bfccb8ab2c581cc4cd6c2da9a8d9ed80ebfe8cbd59b70 fix-voicemail-greet-reset.patch
eaa1c119628e507786884e0377ed04da0a7648ee4597bdb2c59d634a8c3eb903 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
sha512sums
=
"f7f3209ed5c6de4b0c92edd772d12f7a62342289db142d05f7559b0053f9e4e17d65f1d7680abdbda1743a4b30764bc13941c24edb9541265d2c08f99cbe0a64 freeswitch-1.4.20.tar.xz
sha512sums
=
"f7f3209ed5c6de4b0c92edd772d12f7a62342289db142d05f7559b0053f9e4e17d65f1d7680abdbda1743a4b30764bc13941c24edb9541265d2c08f99cbe0a64 freeswitch-1.4.20.tar.xz
38b8729275bbfebaee783e703d19481f3d32b50cfdeb338644b8db2742573ea025702c789b5ce8d5067dcde23c5a16b46231eaadf0b9c5dbff392d410912c772 freeswitch-json-c-0.9.tar.gz
38b8729275bbfebaee783e703d19481f3d32b50cfdeb338644b8db2742573ea025702c789b5ce8d5067dcde23c5a16b46231eaadf0b9c5dbff392d410912c772 freeswitch-json-c-0.9.tar.gz
e2b353721d0316fbd7948f90f9c9561d080eebd50e8dd0449a9c803ffbdb060a469385fadd63f535ade8d627cba37928d8e72ac61d5bcf98f73ca5ebb66549f8 freeswitch-flite-2.0.0-release.tar.bz2
e2b353721d0316fbd7948f90f9c9561d080eebd50e8dd0449a9c803ffbdb060a469385fadd63f535ade8d627cba37928d8e72ac61d5bcf98f73ca5ebb66549f8 freeswitch-flite-2.0.0-release.tar.bz2
...
@@ -255,4 +258,5 @@ a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd3
...
@@ -255,4 +258,5 @@ a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd3
5f085254ca9f5dc196afd39fc55e083b1998e776d9de2428e5657d99077526c33c1fc13f12432598184ce63138447fed7c318c384b743681703f5682dc8e1e50 freeswitch-mod_shout-textrels.patch
5f085254ca9f5dc196afd39fc55e083b1998e776d9de2428e5657d99077526c33c1fc13f12432598184ce63138447fed7c318c384b743681703f5682dc8e1e50 freeswitch-mod_shout-textrels.patch
398dd0f2665415ff40348dc94d26ec7008fb59ec033f9d2c64dc1aa01071021f83f47954e95efc58c4033f22bb6da159e83e3b0d36b99189d5e7535ed6ae70bd system-lame.patch
398dd0f2665415ff40348dc94d26ec7008fb59ec033f9d2c64dc1aa01071021f83f47954e95efc58c4033f22bb6da159e83e3b0d36b99189d5e7535ed6ae70bd system-lame.patch
342abf9f41b7d957759228d5d81aceba1f0862871e29e55f7b46b45001e77e40bc577020fc0f3e693645f39c54a69a13d16ad17776bc49b1f0f05a244c98d5f8 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
342abf9f41b7d957759228d5d81aceba1f0862871e29e55f7b46b45001e77e40bc577020fc0f3e693645f39c54a69a13d16ad17776bc49b1f0f05a244c98d5f8 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
2cceb0d8a108499467047874a312046e17b252c3b5c0fa722069750345a9bd62fdfd6c4d13bc7fa7b1bd7be3b4b783f649f78995863c509949ead35a2270d704 fix-voicemail-greet-reset.patch"
2cceb0d8a108499467047874a312046e17b252c3b5c0fa722069750345a9bd62fdfd6c4d13bc7fa7b1bd7be3b4b783f649f78995863c509949ead35a2270d704 fix-voicemail-greet-reset.patch
f1edca43322a767b28f86f58921584121254cd3dea8a4f03f120794eb82ebbcc7161b6d2c2a139e7ca69491f345462f2a5e5fbaffd45883ba2024e453e17c69d 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment