Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
003a5bc1
Commit
003a5bc1
authored
7 years ago
by
Shiz ...
Committed by
Jakub Jirutka
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/llvm-libunwind: upgrade to 4.0.0
parent
658eb1da
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/llvm-libunwind/APKBUILD
+17
-23
17 additions, 23 deletions
community/llvm-libunwind/APKBUILD
community/llvm-libunwind/no-exec-stack.patch
+19
-0
19 additions, 0 deletions
community/llvm-libunwind/no-exec-stack.patch
with
36 additions
and
23 deletions
community/llvm-libunwind/APKBUILD
+
17
−
23
View file @
003a5bc1
...
@@ -2,9 +2,9 @@
...
@@ -2,9 +2,9 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
llvm-libunwind
pkgname
=
llvm-libunwind
_pkgname
=
libunwind
_pkgname
=
libunwind
pkgver
=
3.9.1
pkgver
=
4.0.0
_llvmver
=
3.9
_llvmver
=
${
pkgver
%%.*
}
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"LLVM version of libunwind library"
pkgdesc
=
"LLVM version of libunwind library"
url
=
"http://llvm.org/"
url
=
"http://llvm.org/"
arch
=
"all !ppc64le !s390x"
arch
=
"all !ppc64le !s390x"
...
@@ -12,37 +12,31 @@ license="BSD"
...
@@ -12,37 +12,31 @@ license="BSD"
depends_dev
=
"!libunwind-dev"
depends_dev
=
"!libunwind-dev"
makedepends
=
"cmake llvm
$_llvmver
-dev"
makedepends
=
"cmake llvm
$_llvmver
-dev"
subpackages
=
"
$pkgname
-dev"
subpackages
=
"
$pkgname
-dev"
source
=
"http://www.llvm.org/releases/
$pkgver
/
$_pkgname
-
$pkgver
.src.tar.xz"
source
=
"http://www.llvm.org/releases/
$pkgver
/
$_pkgname
-
$pkgver
.src.tar.xz
no-exec-stack.patch"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
.src"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
.src"
options
=
"!check"
options
=
"!check"
build
()
{
build
()
{
local
flag
;
for
flag
in
0 1
;
do
cd
"
$builddir
"
mkdir
-p
"
$builddir
"
/build-
$flag
cd
"
$builddir
"
/build-
$flag
cmake ..
\
cmake
\
-DCMAKE_BUILD_TYPE
=
MinSizeRel
\
-DCMAKE_BUILD_TYPE
=
MinSizeRel
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
-DCMAKE_VERBOSE_MAKEFILE
=
ON
\
-DLLVM_CONFIG_PATH
=
"/usr/lib/llvm
$_llvmver
/bin/llvm-config"
\
-DLIBUNWIND_ENABLE_SHARED
=
$flag
\
-DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG
=
OFF
-DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG
=
0
\
make
-DLLVM_CONFIG
=
"/usr/bin/llvm-config-
$_llvmver
"
make
done
}
}
package
()
{
package
()
{
local
flag
;
for
flag
in
0 1
;
do
make
install
-C
"
$builddir
"
/build-
$flag
DESTDIR
=
"
$pkgdir
"
done
cd
"
$builddir
"
cd
"
$builddir
"
make
install
DESTDIR
=
"
$pkgdir
"
mkdir
-p
"
$pkgdir
"
/usr/include
mkdir
-p
"
$pkgdir
"
/usr/include
cp
include/
*
.h
"
$pkgdir
"
/usr/include/
cp
include/
*
.h
"
$pkgdir
"
/usr/include/
}
}
sha512sums
=
"a80f5d0660e209f5bf709316b5df2ca63b9f0db49f5f74dfe9c9e580c654f61a15acc071a739fdb84baf5ffa9420b92498f8560331173642d80f6b74e1e2afb7 libunwind-3.9.1.src.tar.xz"
sha512sums
=
"c3c934b70830ef5496c9d24c469b702eb4408abd4fe4dd9e0832230b064dc78d23b02ed2a5ce9a099dea76c3d43cbf41d59c6cda189f990d5593c7d3cd5c79dd libunwind-4.0.0.src.tar.xz
2a61580331a9c8e5f9d4a12a845be187db65434257bb635eb509db43355709de0f17ddd8a589e0c8ee89ed29c0dc1cefd0fd9d11e4a0eb875b14ad4833063d11 no-exec-stack.patch"
This diff is collapsed.
Click to expand it.
community/llvm-libunwind/no-exec-stack.patch
0 → 100644
+
19
−
0
View file @
003a5bc1
Remove the gatekeeping to set a non-executable stack for libunwind,
as we don't define any of these directives but still want it.
diff -Nru a/src/assembly.h b/src/assembly.h
--- a/src/assembly.h 2016-10-23 21:48:47.000000000 +0000
+++ b/src/assembly.h 2017-05-16 12:38:47.209169931 +0000
@@ -47,12 +47,7 @@
#define SYMBOL_IS_FUNC(name) .type name,@function
#endif
-#if defined(__GNU__) || defined(__ANDROID__) || defined(__FreeBSD__) || \
- defined(__Fuchsia__)
#define NO_EXEC_STACK_DIRECTIVE .section .note.GNU-stack,"",%progbits
-#else
-#define NO_EXEC_STACK_DIRECTIVE
-#endif
#else
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment