Skip to content
Snippets Groups Projects
Commit 97f2ae65 authored by Fraser Waters's avatar Fraser Waters Committed by Andy Postnikov
Browse files

testing/pulumi: upgrade to 2.20.0

parent 1146404f
No related branches found
No related tags found
No related merge requests found
Workaround some issues with the pulumi build pipeline.
Currently the build system assumes your in a git repo to get the version, and
doesn't quite provide a way to build just the native components we need to
apk package.
Currently the build system doesn't quite provide a way to build
just the native components we need to apk package.
index 7f2aa25f9..b1cb72f43 100755
--- a/scripts/get-version
+++ b/scripts/get-version
@@ -6,6 +6,12 @@ if [ $# -eq 0 ]; then
exit 1
fi
+# Allow version to be set manually when building outside of git repo
+if [ -n "${PULUMI_VERSION+x}" ]; then
+ echo "${PULUMI_VERSION}"
+ exit 0
+fi
+
COMMITISH=$1
DIRTY_TAG=""
EXACT=0
diff --git a/Makefile b/Makefile
index 0b81a9de2..26a2f8e8a 100644
--- a/Makefile
......
# Contributor: Fraser Waters <frassle@gmail.com>
# Maintainer: Fraser Waters <frassle@gmail.com>
pkgname=pulumi
pkgver=2.16.2
pkgrel=1
pkgver=2.20.0
pkgrel=0
pkgdesc="Pulumi's Infrastructure as Code SDK"
url="https://github.com/pulumi/pulumi"
# x86_64 is the only supported architecture by pulumi
......@@ -37,5 +37,5 @@ package() {
install -Dm755 -t "$pkgdir"/usr/bin "$srcdir"/opt/bin/*
}
sha512sums="dee178215b55e869017a9330a80e0e93ebf9a9ce9eb8d34c192d6812bfde50e607261c7442c4d4f1fb6feffb77831b14144f140fe9d3e66d5240fe8ca1364bbd pulumi-2.16.2.tar.gz
e096ba0c25f53590bcb778dae21ed9505bfff498a78aa0aff79286f0991510d31dab2fc7e6e479d1a351444d17fe2a0df320ffe14823446bec6ea4d1f2f17e16 10-install1.patch"
sha512sums="7b756336fd0259027a1e22ecf8fb26efaaa3653943e4d3c653d9c35a9fa1312a886d2fb18efdf82fe7f1a9c4ade1d690d8e85ec811f8b606d76e5efde38796f7 pulumi-2.20.0.tar.gz
96783665ebb3993ef767d1e35781901ef115508c527e868c5816e37850b2e28372b11f1878c5c18c3cd276041cb85761ee50a1d838cf95dc21f19befb895bfca 10-install1.patch"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment