Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
96b8ef2b
Commit
96b8ef2b
authored
4 years ago
by
Milan P. Stanić
Browse files
Options
Downloads
Patches
Plain Diff
main/lxc: upgrade to 4.0.6
remove mountinfo_fails.patch, fixed upstream
parent
57755f48
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/lxc/APKBUILD
+3
-5
3 additions, 5 deletions
main/lxc/APKBUILD
main/lxc/mountinfo_fails.patch
+0
-43
0 additions, 43 deletions
main/lxc/mountinfo_fails.patch
with
3 additions
and
48 deletions
main/lxc/APKBUILD
+
3
−
5
View file @
96b8ef2b
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
lxc
pkgname
=
lxc
pkgver
=
4.0.
5
pkgver
=
4.0.
6
_pkgver
=
${
pkgver
/_rc/.rc
}
_pkgver
=
${
pkgver
/_rc/.rc
}
pkgrel
=
1
pkgrel
=
1
pkgdesc
=
"Userspace interface for the Linux kernel containment features"
pkgdesc
=
"Userspace interface for the Linux kernel containment features"
...
@@ -41,7 +41,6 @@ subpackages="
...
@@ -41,7 +41,6 @@ subpackages="
source
=
"https://linuxcontainers.org/downloads/lxc/lxc-
$_pkgver
.tar.gz
source
=
"https://linuxcontainers.org/downloads/lxc/lxc-
$_pkgver
.tar.gz
lxc.initd
lxc.initd
lxc.confd
lxc.confd
mountinfo_fails.patch
"
"
# secfixes:
# secfixes:
...
@@ -165,7 +164,6 @@ bashcomp() {
...
@@ -165,7 +164,6 @@ bashcomp() {
rmdir
"
$pkgdir
"
/etc/bash_completion.d
rmdir
"
$pkgdir
"
/etc/bash_completion.d
}
}
sha512sums
=
"
d536e767f4b7c1ea974469a19f89ddbcebbc3f8c7922b174b966fb2e80ae33199a8a915a962da9cbc7e075442555bc355525f2d4f8e76498b8a7e49f46dc006f
lxc-4.0.
5
.tar.gz
sha512sums
=
"
98514796ef2091a291516ed7fde737df07ccfe374a0f8b4314e0ee992837e98ed02aa9f7809f8808a2f5ee1c7ae2dcea163531cdaedbb577211eeb9beff90c15
lxc-4.0.
6
.tar.gz
b74ffe7c3e8f193265a90ffeb6e5743b1212bc1416b898e5a7e59ddd7f06fc77dc34e2dcbb3614038ac6222a95e2b9beb9f03ab734c991837203ab626b1b091f lxc.initd
b74ffe7c3e8f193265a90ffeb6e5743b1212bc1416b898e5a7e59ddd7f06fc77dc34e2dcbb3614038ac6222a95e2b9beb9f03ab734c991837203ab626b1b091f lxc.initd
91de43db5369a9e10102933514d674e9c875218a1ff2910dd882e5b9c308f9e430deacb13d1d7e0b2ed1ef682d0bb035aa6f8a6738f54fa2ca3a05acce04e467 lxc.confd
91de43db5369a9e10102933514d674e9c875218a1ff2910dd882e5b9c308f9e430deacb13d1d7e0b2ed1ef682d0bb035aa6f8a6738f54fa2ca3a05acce04e467 lxc.confd"
5e203e66f3e6bbc5f6a0ac7e04d69b7f907ff9bd3458285badbb9f6ba50bbcc14fdd388222d8de9c160e45e1f25a59eeb9e2906e33cdfa488d885b7eb7387d0c mountinfo_fails.patch"
This diff is collapsed.
Click to expand it.
main/lxc/mountinfo_fails.patch
deleted
100644 → 0
+
0
−
43
View file @
57755f48
From a39fc34bd6842ad1adc6144391071d8b1078667e Mon Sep 17 00:00:00 2001
From: Christian Brauner <christian.brauner@ubuntu.com>
Date: Mon, 16 Nov 2020 12:30:18 +0100
Subject: [PATCH] conf: switch to fd_to_fd() when copying mountinfo
Closes: #3580.
Link: https://bugzilla.kernel.org/show_bug.cgi?id=209971
Suggested-by: Joan Bruguera <joanbrugueram@gmail.com>
Signed-off-by: Christian Brauner <christian.brauner@ubuntu.com>
---
src/lxc/conf.c | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/src/lxc/conf.c b/src/lxc/conf.c
index d36d9063b6..84d16d7749 100644
--- a/src/lxc/conf.c
+++ b/src/lxc/conf.c
@@ -2980,9 +2980,9 @@
void turn_into_dependent_mounts(void)
__do_free char *line = NULL;
__do_fclose FILE *f = NULL;
__do_close int memfd = -EBADF, mntinfo_fd = -EBADF;
- int ret;
- ssize_t copied;
size_t len = 0;
+ ssize_t copied;
+ int ret;
mntinfo_fd = open("/proc/self/mountinfo", O_RDONLY | O_CLOEXEC);
if (mntinfo_fd < 0) {
@@ -3006,12 +3006,8 @@
void turn_into_dependent_mounts(void)
}
}
-again:
- copied = lxc_sendfile_nointr(memfd, mntinfo_fd, NULL, LXC_SENDFILE_MAX);
+ copied = fd_to_fd(mntinfo_fd, memfd);
if (copied < 0) {
- if (errno == EINTR)
- goto again;
-
SYSERROR("Failed to copy \"/proc/self/mountinfo\"");
return;
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment