Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
93632cfe
Commit
93632cfe
authored
4 years ago
by
Bart Ribbers
Browse files
Options
Downloads
Patches
Plain Diff
community/smooth: upgrade to 0.9.7
parent
bd4b0a84
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Pipeline
#72360
canceled
4 years ago
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/smooth/APKBUILD
+4
-7
4 additions, 7 deletions
community/smooth/APKBUILD
community/smooth/fix-drawing-issue-on-kde.patch
+0
-38
0 additions, 38 deletions
community/smooth/fix-drawing-issue-on-kde.patch
with
4 additions
and
45 deletions
community/smooth/APKBUILD
+
4
−
7
View file @
93632cfe
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
smooth
pkgver
=
0.9.
6
pkgver
=
0.9.
7
pkgrel
=
0
arch
=
"all"
url
=
"https://github.com/enzo1982/smooth"
...
...
@@ -15,16 +15,14 @@ makedepends="
libx11-dev
libxml2-dev
"
source
=
"https://github.com/enzo1982/smooth/archive/v
$pkgver
/smooth-v
$pkgver
.tar.gz
fix-drawing-issue-on-kde.patch
"
source
=
"https://github.com/enzo1982/smooth/archive/v
$pkgver
/smooth-v
$pkgver
.tar.gz"
subpackages
=
"
$pkgname
-dev"
options
=
"!check"
# No tests
prepare
()
{
default_prepare
find
"
$builddir
"
-type
f
-exec
sed
-i
's|/usr/local|/usr|g'
{}
\;
find
.
-type
f
-exec
sed
-i
's|/usr/local|/usr|g'
{}
\;
}
build
()
{
...
...
@@ -35,5 +33,4 @@ package() {
DESTDIR
=
"
$pkgdir
"
make
install
}
sha512sums
=
"ee4ab539c05ff68a01329aecb50aabdbc597eda954e310840ef5d50c1ea735fda4f027adb2ba047f9a7e699dce1ff868e2689261e941708eab3a0a4cf72945a6 smooth-v0.9.6.tar.gz
a5be6b2db828bde83dbb26462e5fb483ed336bfd31b965058d48e3dd864e76c33369e6df3b6a7f7020983a55e34b20a342907b6dff201cb0e7f654779f942a96 fix-drawing-issue-on-kde.patch"
sha512sums
=
"d3def3859f24222bd2c46e47d9e9b7208dadaa460b60c0937a62e549565a01f8f1af9eef454914d7b0be69ab76b5057292861de6472be381cfae2fb5281a30dc smooth-v0.9.7.tar.gz"
This diff is collapsed.
Click to expand it.
community/smooth/fix-drawing-issue-on-kde.patch
deleted
100644 → 0
+
0
−
38
View file @
bd4b0a84
From 0db8f929b935650698d3bcb09a52cc30e4abbb2e Mon Sep 17 00:00:00 2001
From: Robert Kausch <robert.kausch@freac.org>
Date: Tue, 13 Oct 2020 20:26:48 +0200
Subject: [PATCH] Fix drawing issues on KDE systems.
---
ChangeLog | 4 ++++
classes/gui/window/window.cpp | 3 ++-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index ec5724e3..1ce4786a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
ChangeLog for smooth
+dd.mm.20 hh:mm - smooth alpha 0.9.7
+
+- window.cpp - fixed drawing issues on KDE systems
+
10.10.20 18:20 - smooth alpha 0.9.6
- surfacegdi.cpp - fixed too high DPI values being reported
diff --git a/classes/gui/window/window.cpp b/classes/gui/window/window.cpp
index b5523160..22a30836 100755
--- a/classes/gui/window/window.cpp
+++ b/classes/gui/window/window.cpp
@@ -578,7 +578,8 @@
S::Int S::GUI::Window::Process(Int message, Int wParam, Int lParam)
{
Bool resized = (updateRect == Rect(Point(-1, -1), Size(0, 0)));
- updateRect = backend->GetUpdateRect();
+ if (resized) updateRect = Rect(Point(0, 0), GetRealSize());
+ else updateRect = backend->GetUpdateRect();
Paint(resized ? SP_PAINT : SP_UPDATE);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment