Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
2e1f1832
Commit
2e1f1832
authored
8 years ago
by
Francesco Colista
Browse files
Options
Downloads
Patches
Plain Diff
community/certbot: renamed from letencrypt, added wrapper for letsencrypt binary, upgrade to 0.6.0
parent
29aefa04
Loading
Loading
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/certbot/APKBUILD
+14
-8
14 additions, 8 deletions
community/certbot/APKBUILD
community/certbot/letsencrypt-wrapper
+6
-0
6 additions, 0 deletions
community/certbot/letsencrypt-wrapper
with
20 additions
and
8 deletions
community/
letsencryp
t/APKBUILD
→
community/
certbo
t/APKBUILD
+
14
−
8
View file @
2e1f1832
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname
=
letsencryp
t
pkgver
=
0.
5
.0
pkgname
=
certbo
t
pkgver
=
0.
6
.0
pkgrel
=
0
pkgdesc
=
"An ACME client that can update Apache/Nginx configurations"
url
=
"https://github.com/
letsencrypt/letsencryp
t"
url
=
"https://github.com/
certbot/certbo
t"
arch
=
"noarch"
license
=
"Apache"
depends
=
"py-setuptools py-mock py-acme py-configargparse py-configobj
...
...
@@ -15,13 +15,15 @@ depends="py-setuptools py-mock py-acme py-configargparse py-configobj
# so they get pulled in when bootstrapping.
_depends_acme
=
"py-setuptools py-cryptography py-ndg_httpsclient py-asn1 py-openssl
py-tz py-rfc3339 py-requests py-six py-werkzeug"
provides
=
"letsencrypt"
depends_dev
=
""
makedepends
=
"
$depends_dev
$_depends_acme
"
install
=
""
subpackages
=
"py-acme:acme"
source
=
"letsencrypt-
$pkgver
.tar.gz::https://github.com/letsencrypt/letsencrypt/archive/v
$pkgver
.tar.gz"
source
=
"certbot-
$pkgver
.tar.gz::https://github.com/certbot/certbot/archive/v
$pkgver
.tar.gz
letsencrypt-wrapper"
_builddir
=
"
$srcdir
"
/
letsencrypt
-
$pkgver
_builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
build
()
{
cd
"
$_builddir
"
python setup.py build
||
return
1
...
...
@@ -30,6 +32,7 @@ build() {
package
()
{
cd
"
$_builddir
"
python setup.py
install
--prefix
=
/usr
--root
=
"
$pkgdir
"
||
return
1
install
-m755
"
$srcdir
"
/letsencrypt-wrapper
"
$pkgdir
"
/usr/bin/letsencrypt
}
acme
()
{
...
...
@@ -40,6 +43,9 @@ acme() {
python setup.py
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
||
return
1
}
md5sums
=
"767521d7b5ae1f648071128356e8de5a letsencrypt-0.5.0.tar.gz"
sha256sums
=
"503535fa356c45b46a166ea84875bb1fd43e994afee1485bbc3b6849d46c5d43 letsencrypt-0.5.0.tar.gz"
sha512sums
=
"bffa5123a702c02d74c21453a5f5583055986132eb4ae58b72d066c1c5514a1b6832fc381490998c107fbfc1ac8cd403b19b9a1c87006db4e6081e686c2a2fd0 letsencrypt-0.5.0.tar.gz"
md5sums
=
"350c3cecbb066b96739a50cba04f5d4c certbot-0.6.0.tar.gz
98c8ab7fede335bd00b0f0d85cd447e1 letsencrypt-wrapper"
sha256sums
=
"58eaa6be4ae90af07d682296e42dbac924b5602c51002445059596313e182a09 certbot-0.6.0.tar.gz
4f3a6b71ce80f96f65204fe9c1509a299b5d856a1cc60b99c0dd869269badeff letsencrypt-wrapper"
sha512sums
=
"966fdbff13ac9651ebb5fafae86a58a45538d57a43eb6d157358bbecef4286634bb61dd13b94e0ca5b006980a35cc5fe55b4a12efdeadc2530653d844516c926 certbot-0.6.0.tar.gz
db22121e32f9654b9b27883fc405b727ba85426d4122b901bf494d3ccf12bf1d2093b68979c005551762cc1ea80c5e5a442098504e3aa0e1b9286dca4819c24c letsencrypt-wrapper"
This diff is collapsed.
Click to expand it.
community/certbot/letsencrypt-wrapper
0 → 100644
+
6
−
0
View file @
2e1f1832
#!/bin/sh
echo
>
&2
echo
"Warning: letsencrypt has been renamed in certbot."
>
&2
echo
"From the next version, this wrapper will be removed."
>
&2
echo
>
&2
/usr/bin/certbot
$@
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment