Skip to content
Snippets Groups Projects
Forked from alpine / aports
73040 commits behind the upstream repository.
APKBUILD 989 B
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-prettytable3
pkgver=3.4.0
pkgrel=0
pkgdesc="Display tabular data in a visually appealing ASCII table format"
url="https://github.com/jazzband/prettytable"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-wcwidth !py3-prettytable"
makedepends="py3-setuptools py3-setuptools_scm"
checkdepends="py3-pytest py3-pytest-lazy-fixture"
source="https://files.pythonhosted.org/packages/source/p/prettytable/prettytable-$pkgver.tar.gz"
builddir="$srcdir/prettytable-$pkgver"

build() {
	python3 setup.py build
}

check() {
	python3 setup.py install --root="test_install"
	PYTHONPATH=$(find test_install -name site-packages) pytest
}

package() {
	python3 setup.py install --prefix=/usr --root="$pkgdir"
}

sha512sums="
3d79007d113737653a871f6ef23d8631cd2810a0c44436933ff063efeaa36d91bc2a98cd7dda526e459c0fbb522ed1f1dd4f45dd0c7c55e24f5b1a0c22bd90d3  prettytable-3.4.0.tar.gz
"