Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
J0WI
aports
Commits
98b16a02
Commit
98b16a02
authored
4 years ago
by
Rasmus Thomsen
Browse files
Options
Downloads
Patches
Plain Diff
community/webkit2gtk: upgrade to 2.30.3
fixes #12133
parent
77e78623
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/webkit2gtk/APKBUILD
+7
-8
7 additions, 8 deletions
community/webkit2gtk/APKBUILD
community/webkit2gtk/use-versioned-libwpe.patch
+0
-13
0 additions, 13 deletions
community/webkit2gtk/use-versioned-libwpe.patch
with
7 additions
and
21 deletions
community/webkit2gtk/APKBUILD
+
7
−
8
View file @
98b16a02
...
...
@@ -3,11 +3,11 @@
# Contributor: Jiri Horner <laeqten@gmail.com>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname
=
webkit2gtk
pkgver
=
2.
28.4
pkgver
=
2.
30.3
pkgrel
=
0
pkgdesc
=
"Portable web rendering engine WebKit for GTK+"
url
=
"https://webkitgtk.org/"
arch
=
"all"
arch
=
"all
!mips !mips64
"
license
=
"LGPL-2.0-or-later AND BSD-2-Clause"
depends
=
"bubblewrap xdg-dbus-proxy dbus:org.freedesktop.Secrets"
makedepends
=
"
...
...
@@ -42,7 +42,7 @@ makedepends="
openjpeg-tools
pango-dev
paxmark
python
2
python
3
ruby
samurai
sqlite-dev
...
...
@@ -59,7 +59,6 @@ source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
musl-fixes.patch
fix-openjpeg.patch
lower-stack-usage.patch
use-versioned-libwpe.patch
"
builddir
=
"
$srcdir
/webkitgtk-
$pkgver
"
...
...
@@ -193,7 +192,7 @@ build() {
# disable _FORTIFY_SOURCE to work around:
# cc1plus: out of memory allocating 65536 bytes after a total of 3131101184 bytes
x86
)
CXXFLAGS
=
"
$CXXFLAGS
-U_FORTIFY_SOURCE"
;;
armhf|
armv7|
ppc64le|s390x
)
_archopt
=
"-DENABLE_JIT=OFF"
;;
armhf|ppc64le|s390x
)
_archopt
=
"-DENABLE_JIT=OFF"
;;
esac
# reduce memory usage on 32 bit
...
...
@@ -217,6 +216,7 @@ build() {
-DUSE_WOFF2
=
ON
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DUSE_LD_GOLD
=
OFF
\
-DUSE_SYSTEMD
=
OFF
\
$_archopt
\
..
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=923476
...
...
@@ -234,9 +234,8 @@ package() {
paxmark
-m
"
$pkgdir
"
/usr/libexec/webkit2gtk-4.0/WebKitWebProcess
}
sha512sums
=
"
227cd4066235180521a32a83d3a906212adf4f234f15a1fff4ac86b48e39c431f1e0cb4a56f62924015099a0c8909a73a21a56f8dc71a16c53ac65de4a5773a1
webkitgtk-2.
28.4
.tar.xz
sha512sums
=
"
cbb8298bdb791eb60a214c36ec9ced398fc5c07f580d60d001483ca3f616a309394013239affd16f6eefd8c2fb178bbf5b566ab4480fe3349e1856c80ec78ddf
webkitgtk-2.
30.3
.tar.xz
e1537b9937af1cb936669d405993a52204cb9968b8b3161cb12a3f3f1343c260088c9490fcd7a7deeab6dbabdb5f7ce7e6cb2f857b9f0a4205aba6db2b11fb20 fix-fast-memory-disabled.patch
4c0093e4a38c8ceb3ac92b94539ec1417241814a84abd157442f53f710ecbaf9c2345e258b8ad86d5e0908cacbfca6cad28dedd11c127756b65428f359ba9fcc musl-fixes.patch
c517c012f5630ef6be5be7d9592c5e042a070f849a141859edefa7984acb98dbd0d718fe6613cd35ba3b7d8530beebcc7408fd077cd914ed335c5e524e9e746a fix-openjpeg.patch
7d883fc35d0c6bfaa6bff8e9dbcaeaa9b7d7322852e874d8acc78d41a5aad5595650ec62444048e43aa349471cb16e5aed29e684207fc8d3421030e878ba1fa9 lower-stack-usage.patch
82540900a7117e56336fd320692bf4201047a1473050ff3722ba89623551d50925d9e3dde816ed38bfe2145397362ad7eec50332cb53822250c71eea65ec51f0 use-versioned-libwpe.patch"
7d883fc35d0c6bfaa6bff8e9dbcaeaa9b7d7322852e874d8acc78d41a5aad5595650ec62444048e43aa349471cb16e5aed29e684207fc8d3421030e878ba1fa9 lower-stack-usage.patch"
This diff is collapsed.
Click to expand it.
community/webkit2gtk/use-versioned-libwpe.patch
deleted
100644 → 0
+
0
−
13
View file @
77e78623
diff --git a/Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp b/Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp
index 180f392a..85639a11 100644
--- a/Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp
+++ b/Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp
@@ -115,7 +115,7 @@
void WebProcessPool::platformInitializeWebProcess(const WebProcessProxy& process
#if PLATFORM(WAYLAND)
if (WebCore::PlatformDisplay::sharedDisplay().type() == WebCore::PlatformDisplay::Type::Wayland) {
#if USE(WPE_RENDERER)
- wpe_loader_init("libWPEBackend-fdo-1.0.so");
+ wpe_loader_init("libWPEBackend-fdo-1.0.so.1");
if (wpe_fdo_initialize_for_egl_display(WebCore::PlatformDisplay::sharedDisplay().eglDisplay())) {
parameters.hostClientFileDescriptor = wpe_renderer_host_create_client();
parameters.implementationLibraryName = FileSystem::fileSystemRepresentation(wpe_loader_get_loaded_implementation_library_name());
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment