testing/ldc: upgrade to 1.19.0

The package used to depend on itself (and was broken),
now using gdc we have a more sustainable bootstrap path.
It needs to be upgrade to v1.19.0 to include the fixes for
Musl which were made while porting 'gcc-gdc'.
7 jobs for !2703 with ldc-gdc in 20 minutes and 54 seconds (queued for 1 second)
detached
Status Job ID Name Coverage
  Lint
passed #32177
docker-alpine x86_64
lint

00:00:33

 
  Build
passed #32182
docker-alpine ci-build aarch64
build-aarch64

00:00:22

passed #32183
docker-alpine ci-build armv7
build-armv7

00:00:27

passed #32181
docker-alpine ci-build ppc64le
build-ppc64le

00:00:35

passed #32180
docker-alpine ci-build s390x
build-s390x

00:00:22

passed #32179
docker-alpine ci-build x86
build-x86

00:00:21

passed #32178
docker-alpine ci-build x86_64
build-x86_64

00:20:19