Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Peter Shkenev
aports
Commits
63173ce9
Commit
63173ce9
authored
9 years ago
by
Stuart Cardall
Committed by
Natanael Copa
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/udevil: move post-install message
parent
ce4296a6
Loading
Loading
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
testing/udevil/APKBUILD
+14
-5
14 additions, 5 deletions
testing/udevil/APKBUILD
testing/udevil/udevil.apk-post-msg
+11
-0
11 additions, 0 deletions
testing/udevil/udevil.apk-post-msg
testing/udevil/udevil.post-install
+0
-22
0 additions, 22 deletions
testing/udevil/udevil.post-install
with
25 additions
and
27 deletions
testing/udevil/APKBUILD
+
14
−
5
View file @
63173ce9
...
...
@@ -8,10 +8,13 @@ url="http://ignorantguru.github.io/udevil"
arch
=
"all"
license
=
"GPL3+"
makedepends
=
"
$depends_dev
glib-dev udev-dev intltool"
install
=
"
$pkgname
.post-install
$pkgname
.pre-install"
install
=
"
$pkgname
.pre-install"
subpackages
=
"
$pkgname
-lang"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/IgnorantGuru/
$pkgname
/archive/
$pkgver
.tar.gz"
pkggroups
=
"plugdev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/IgnorantGuru/
$pkgname
/archive/
$pkgver
.tar.gz
$pkgname
.apk-post-msg
"
_builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
prepare
()
{
local
i
...
...
@@ -36,8 +39,14 @@ package() {
make
-j1
DESTDIR
=
"
$pkgdir
"
install
||
return
1
chown
root:plugdev
"
$pkgdir
"
/usr/bin/udevil
||
return
1
chmod
u+s,go-s,o-x
"
$pkgdir
"
/usr/bin/udevil
# remove SUID bit
mkdir
-p
"
$pkgdir
/usr/share/apk-tools/
$pkgname
"
install
-m644
"
$srcdir
/
$pkgname
.apk-post-msg"
"
$pkgdir
/usr/share/apk-tools/
$pkgname
/post-install-message"
||
return
1
# chmod ugo-s,ugo+x "$pkgdir"/usr/bin/udevil #remove SUID bit completely
}
md5sums
=
"281aa065d92c679cb41728069e72b272 udevil-0.4.4.tar.gz"
sha256sums
=
"ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c udevil-0.4.4.tar.gz"
sha512sums
=
"adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 udevil-0.4.4.tar.gz"
md5sums
=
"281aa065d92c679cb41728069e72b272 udevil-0.4.4.tar.gz
cd426d9d4f6387eb6eca51c661525d1b udevil.apk-post-msg"
sha256sums
=
"ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c udevil-0.4.4.tar.gz
be09f2c03a852eee3e2b94250664e8a63b33df631a098e500d730a56c839789a udevil.apk-post-msg"
sha512sums
=
"adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 udevil-0.4.4.tar.gz
060e17a1847a40f5ad1f19d803c14de8be2bcde205cf23fbbd73f0167c577f4be04749476e31e6e153033f0b92a70b264b553bb4cc3c077acdb39b117a0f9814 udevil.apk-post-msg"
This diff is collapsed.
Click to expand it.
testing/udevil/udevil.apk-post-msg
0 → 100644
+
11
−
0
View file @
63173ce9
To mount / unmount devices without the root password: add your user account to the 'plugdev' group.
Optional dependencies:
zenity: (devmon popups)
davfs2: (mount WebDAV resources)
cifs-utils: (mounting samba shares)
curlftpfs: (mounting ftp shares)
nfs-utils: (mounting nfs shares)
sshfs-fuse: (mounting sftp shares)
eject: (eject via devmon)
This diff is collapsed.
Click to expand it.
testing/udevil/udevil.post-install
deleted
100644 → 0
+
0
−
22
View file @
ce4296a6
#!/bin/sh
NORMAL
=
"
\0
33[1;0m"
STRONG
=
"
\0
33[1;1m"
GREEN
=
"
\0
33[1;32m"
print_strong
()
{
local
prompt
=
"
${
STRONG
}
$1
${
GREEN
}
$2
${
NORMAL
}
"
printf
"
${
prompt
}
%s
\n
"
}
print_strong
"
\n
To mount / unmount devices without the root password:"
" add your user account to the 'plugdev' group."
print_strong
"
\n
Optional dependencies:"
print_strong
"
\n
zenity: "
" (devmon popups)"
print_strong
"davfs2: "
" (mount WebDAV resources)"
print_strong
"cifs-utils: "
" (mounting samba shares)"
print_strong
"curlftpfs: "
" (mounting ftp shares)"
print_strong
"nfs-utils: "
" (mounting nfs shares)"
print_strong
"sshfs-fuse: "
" (mounting sftp shares)"
print_strong
"eject: "
" (eject via devmon)"
exit
0
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment