Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Akihiro Suda
aports
Commits
c02879ef
Commit
c02879ef
authored
12 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/squid: upgrade to 3.2.0.19
parent
568f9648
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/squid/APKBUILD
+3
-5
3 additions, 5 deletions
main/squid/APKBUILD
main/squid/bug3577.patch
+0
-59
0 additions, 59 deletions
main/squid/bug3577.patch
with
3 additions
and
64 deletions
main/squid/APKBUILD
+
3
−
5
View file @
c02879ef
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
squid
pkgname
=
squid
pkgver
=
3.2.0.1
8
pkgver
=
3.2.0.1
9
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"A full-featured Web proxy cache server."
pkgdesc
=
"A full-featured Web proxy cache server."
url
=
"http://www.squid-cache.org"
url
=
"http://www.squid-cache.org"
install
=
"squid.pre-install squid.pre-upgrade"
install
=
"squid.pre-install squid.pre-upgrade"
...
@@ -21,7 +21,6 @@ langdir="/usr/share/squid/errors"
...
@@ -21,7 +21,6 @@ langdir="/usr/share/squid/errors"
source
=
"http://www.squid-cache.org/Versions/v3/3.2/squid-
$pkgver
.tar.bz2
source
=
"http://www.squid-cache.org/Versions/v3/3.2/squid-
$pkgver
.tar.bz2
squid-3.2.0.16-loggable-urlgroup.patch
squid-3.2.0.16-loggable-urlgroup.patch
cf_gen-pthread.patch
cf_gen-pthread.patch
bug3577.patch
squid.initd
squid.initd
squid.confd
squid.confd
$pkgname
.logrotate
$pkgname
.logrotate
...
@@ -105,10 +104,9 @@ squid_kerb_auth() {
...
@@ -105,10 +104,9 @@ squid_kerb_auth() {
mv
"
$pkgdir
"
/usr/lib/squid/squid_kerb_auth
"
$subpkgdir
"
/usr/lib/squid/
mv
"
$pkgdir
"
/usr/lib/squid/squid_kerb_auth
"
$subpkgdir
"
/usr/lib/squid/
}
}
md5sums
=
"
c062829bc5aff6cd76f3a09ca7ec4026
squid-3.2.0.1
8
.tar.bz2
md5sums
=
"
9c6c134500f301c6c567b75921b39333
squid-3.2.0.1
9
.tar.bz2
16e3b38996d4c5858e1478f8eb650876 squid-3.2.0.16-loggable-urlgroup.patch
16e3b38996d4c5858e1478f8eb650876 squid-3.2.0.16-loggable-urlgroup.patch
c60237de253c02937f272d3b189d7679 cf_gen-pthread.patch
c60237de253c02937f272d3b189d7679 cf_gen-pthread.patch
609bb6ab7b999d7070caa5141758e325 bug3577.patch
905e57c6d41414f54a75a5c0f9f7fac7 squid.initd
905e57c6d41414f54a75a5c0f9f7fac7 squid.initd
2897c725c201be53d3c9a7db0101bdf0 squid.confd
2897c725c201be53d3c9a7db0101bdf0 squid.confd
58823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
58823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
This diff is collapsed.
Click to expand it.
main/squid/bug3577.patch
deleted
100644 → 0
+
0
−
59
View file @
568f9648
--- squid-3.2.0.18.orig/src/comm/ConnOpener.cc
+++ squid-3.2.0.18/src/comm/ConnOpener.cc
@@ -131,6 +131,7 @@
}
if (temporaryFd_ >= 0) {
+ debugs(5, 4, HERE << conn_ << " closing temp FD " << temporaryFd_);
// it never reached fully open, so cleanup the FD handlers
// Note that comm_close() sequence does not happen for partially open FD
Comm::SetSelect(temporaryFd_, COMM_SELECT_WRITE, NULL, NULL, 0);
@@ -141,6 +142,7 @@
}
fd_table[temporaryFd_].timeoutHandler = NULL;
fd_table[temporaryFd_].timeout = 0;
+ close(temporaryFd_);
fd_close(temporaryFd_);
temporaryFd_ = -1;
}
--- squid-3.2.0.18.orig/src/forward.cc
+++ squid-3.2.0.18/src/forward.cc
@@ -84,6 +84,11 @@
if (Comm::IsConnOpen(fwd->serverConnection())) {
comm_remove_close_handler(fwd->serverConnection()->fd, fwdServerClosedWrapper, fwd);
+ debugs(17, 3, HERE << "store entry aborted; closing " <<
+ fwd->serverConnection());
+ fwd->serverConnection()->close();
+ } else {
+ debugs(17, 7, HERE << "store entry aborted; no connection to close");
}
fwd->serverDestinations.clean();
fwd->self = NULL;
--- squid-3.2.0.18.orig/src/http.cc
+++ squid-3.2.0.18/src/http.cc
@@ -1067,7 +1067,7 @@
}
if (EBIT_TEST(entry->flags, ENTRY_ABORTED)) {
- // TODO: should we call abortTransaction() here?
+ abortTransaction("store entry aborted while reading reply");
return;
}
@@ -1346,12 +1346,9 @@
}
if (EBIT_TEST(entry->flags, ENTRY_ABORTED)) {
- /*
- * The above writeReplyBody() call could ABORT this entry,
- * in that case, the server FD should already be closed.
- * there's nothing for us to do.
- */
- (void) 0;
+ // The above writeReplyBody() call may have aborted the store entry.
+ abortTransaction("store entry aborted while storing reply");
+ return;
} else
switch (persistentConnStatus()) {
case INCOMPLETE_MSG: {
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment