Skip to content
Snippets Groups Projects
Commit 6786b39a authored by Natanael Copa's avatar Natanael Copa
Browse files

main/a2ps: build fix for automake 1.12

parent 9dd2f431
No related branches found
No related tags found
No related merge requests found
......@@ -16,16 +16,19 @@ source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname-4.13-manpage-chmod.patch
$pkgname-$pkgver-check-mempcpy.patch
$pkgname-$pkgver-fix-stpcpy-proto.patch
a2ps-automake-1.12.patch
"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
for i in ../*.patch; do
msg "Apllying $i"
patch -p1 -i $i || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
sed -i -e 's/__mempcpy/mempcpy/g' lib/strftime.c src/regex.c \
|| return 1
rm -f aclocal.m4 */aclocal.m4
libtoolize --force --copy || return 1
autoreconf -I m4 || return 1
}
......@@ -50,4 +53,5 @@ md5sums="781ac3d9b213fa3e1ed0d79f986dc8c7 a2ps-4.14.tar.gz
2e493d0bc00d71eb3e8a9b6febc52b69 a2ps-4.13c-emacs.patch
09cc5ed4d3d8ff1b2103e519191e8286 a2ps-4.13-manpage-chmod.patch
42aa39b74f6da8cf6e94185c4fc3e601 a2ps-4.14-check-mempcpy.patch
4b4fbc19a6b79fa64df7e26945fcdcf9 a2ps-4.14-fix-stpcpy-proto.patch"
4b4fbc19a6b79fa64df7e26945fcdcf9 a2ps-4.14-fix-stpcpy-proto.patch
72e8f0a6cd234945df92549d8a5451f8 a2ps-automake-1.12.patch"
--- ./configure.in.orig
+++ ./configure.in
@@ -43,7 +43,6 @@
AC_ISC_POSIX
AC_PROG_CPP
AM_PROG_CC_STDC
-AM_C_PROTOTYPES
AC_PROG_YACC
fp_PROG_ECHO
AC_PROG_GPERF
--- ./lib/Makefile.am.orig
+++ ./lib/Makefile.am
@@ -17,7 +17,6 @@
## Process this file with automake to produce Makefile.in.
## This seems to make problems with some makes
-AUTOMAKE_OPTIONS = $(top_builddir)/lib/ansi2knr
#
# Definition of the local target
--- ./src/Makefile.am.orig
+++ ./src/Makefile.am
@@ -23,9 +23,6 @@
## Process this file with automake to produce Makefile.in
-## Since this package is written in ansi, be ready to un-ansify
-AUTOMAKE_OPTIONS = $(top_builddir)/lib/ansi2knr
-
bin_PROGRAMS = a2ps
DEFS = @DEFS@ -DLOCALEDIR=\"$(datadir)/locale\"
--- ./contrib/sample/Makefile.am.orig
+++ ./contrib/sample/Makefile.am
@@ -25,8 +25,6 @@
## Process this file with automake to produce Makefile.in
-## Since this package is written in ansi, be ready to un-ansify
-AUTOMAKE_OPTIONS = $(top_builddir)/lib/ansi2knr
localedir = $(datadir)/locale
noinst_PROGRAMS = sample
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment