From f61ff84cad4708bc468d35e656f64096daacc896 Mon Sep 17 00:00:00 2001
From: TBK <tbk@jjtc.dk>
Date: Fri, 27 Apr 2018 19:13:11 +0200
Subject: [PATCH] testing/icoutils: new aport

---
 testing/icoutils/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/icoutils/APKBUILD

diff --git a/testing/icoutils/APKBUILD b/testing/icoutils/APKBUILD
new file mode 100644
index 000000000000..6973e5a33d96
--- /dev/null
+++ b/testing/icoutils/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=icoutils
+pkgver=0.32.3
+pkgrel=0
+pkgdesc="Extracts and converts images in MS Windows(R) icon and cursor files."
+url="https://www.nongnu.org/icoutils/"
+arch="all"
+license="GPL-3.0+"
+options="!check" # No test suite
+depends="perl-libwww"
+makedepends="automake autoconf libtool libpng-dev"
+subpackages="$pkgname-doc"
+source="https://download.savannah.gnu.org/releases/icoutils/$pkgname-$pkgver.tar.bz2"
+
+build() {
+	cd "$builddir"
+	./configure \
+		--prefix=/usr \
+		--mandir=/usr/share/man
+	make
+}
+
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="982a051a5dc4a63bb2a9f23e78e5a88e481e5c7a9c25789253e1c396e40d4c093e5a9b399966d660e4f2da21ce15d539cb9d20bfd8126b1138f148b86baa6726  icoutils-0.32.3.tar.bz2"
-- 
GitLab