From f44ddea6a89cebe8633101ac89bca43982f9833d Mon Sep 17 00:00:00 2001
From: J0WI <J0WI@users.noreply.github.com>
Date: Fri, 26 Oct 2018 13:39:22 +0200
Subject: [PATCH] community/py-greenlet: modernize and add check

---
 community/py-greenlet/APKBUILD | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/community/py-greenlet/APKBUILD b/community/py-greenlet/APKBUILD
index 21c8b3d37dd7..ef0fd9258aa2 100644
--- a/community/py-greenlet/APKBUILD
+++ b/community/py-greenlet/APKBUILD
@@ -19,14 +19,20 @@ builddir="$srcdir/$_pkgname-$pkgver"
 build() {
 	cd "$builddir"
 	export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0"
-	python2 setup.py build || return 1
-	python3 setup.py build || return 1
+	python2 setup.py build
+	python3 setup.py build
 }
 
 package() {
 	mkdir -p "$pkgdir"
 }
 
+check() {
+	cd "$builddir"
+	python2 setup.py test
+	python3 setup.py test
+}
+
 _py() {
 	local python=$1
 	pkgdesc="$pkgdesc - $python"
-- 
GitLab