diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index 8ea3118f10444e5bb5707cffe794f1cf6e25d741..fe25f9cc2d58f2cc60dabc423692967f772a1e0e 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -5,7 +5,7 @@
 # Maintainer: Leo <thinkabit.ukim@gmail.com>
 pkgname=pulseaudio
 pkgver=12.2
-pkgrel=3
+pkgrel=4
 pkgdesc="A featureful, general-purpose sound server"
 url="http://www.freedesktop.org/wiki/Software/PulseAudio"
 arch="all !s390x"
@@ -57,7 +57,8 @@ build() {
 		--disable-rpath \
 		--disable-esound \
 		--disable-hal-compat \
-		--enable-x11
+		--enable-x11 \
+		--enable-avahi
 
 	sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
 
@@ -130,6 +131,8 @@ jack() {
 
 zeroconf() {
 	pkgdesc="Pulseaudio zeroconf support"
+	depends="avahi"
+
 	mkdir -p "$subpkgdir"/usr/lib/pulse-$pkgver/modules
 	mv "$pkgdir"/usr/lib/pulse-$pkgver/modules/*avahi*.so \
 		"$pkgdir"/usr/lib/pulse-$pkgver/modules/*zeroconf*.so \