diff --git a/main/gphoto2/APKBUILD b/main/gphoto2/APKBUILD
index 074612b2ba403a3a7a429abfc6456549971c0361..ff21c29b176d380b7bdf1ba76363b723ca4d0acc 100644
--- a/main/gphoto2/APKBUILD
+++ b/main/gphoto2/APKBUILD
@@ -1,18 +1,16 @@
-# Contributor: 
+# Contributor: Leo <thinkabit.ukim@gmail.com>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=gphoto2
-pkgver=2.5.15
+pkgver=2.5.23
 pkgrel=0
 pkgdesc="Commandline utilities for accessing cameras"
 url="http://www.gphoto.org/"
 arch="all"
-license="GPL"
+license="LGPL-2.1-or-later"
 makedepends="libgphoto2-dev popt-dev gettext-dev libjpeg-turbo-dev libtool"
 subpackages="$pkgname-lang $pkgname-doc"
 source="https://sourceforge.net/projects/gphoto/files/gphoto/$pkgver/gphoto2-$pkgver.tar.bz2"
 
-builddir="$srcdir/$pkgname-$pkgver"
-
 build() {
 	cd "$builddir"
 	./configure \
@@ -26,9 +24,14 @@ build() {
 	make
 }
 
+check() {
+	cd "$builddir"
+	make check
+}
+
 package() {
 	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="46058a12a81379f3311911e103cf934b6eb616d7f81180615b385d01e855bf6ce998eb12811b9d032328ebed6acfc4456f3a383cfedb93c6967c9699654d4f40  gphoto2-2.5.15.tar.bz2"
+sha512sums="b5cea3008b5b9de93444fa25b11eab13155d479896920275caada123e0578ed3f84f9b15fe82406c332e64955ba075b642341d88e20a2ee78b42991890bca86b  gphoto2-2.5.23.tar.bz2"