diff --git a/testing/wok/APKBUILD b/testing/wok/APKBUILD
index 17e890acd8bb0c462db3b807bb1b6e357dff174d..bc0947b57a73c50eb224522d823a57295285caf0 100644
--- a/testing/wok/APKBUILD
+++ b/testing/wok/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=wok
 pkgver=2.5.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Webserver of Kimchi - a cherrypy framework for multi-purpose plug-ins"
 url="https://kimchi-project.github.io/wok/"
 arch="noarch"
@@ -12,10 +12,10 @@ depends="python2 nginx logrotate py-cherrypy py2-jsonschema
 	py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt py-cherrypy
 	ttf-opensans ttf-font-awesome"
 makedepends="automake autoconf libtool gettext-dev
-	python2-dev pyflakes libxslt"
-options="!check"
+	python2-dev pyflakes libxslt py-setuptools py2-websockify py2-mock"
+options="!check" # tests fail
 subpackages="$pkgname-lang $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/wok/archive/$pkgver.tar.gz
 	wokd.initd
 	alpine-specific-pushserver.patch
 	alpine-specific-wokd.patch"
@@ -39,7 +39,7 @@ package() {
 		"$pkgdir"/etc/init.d/wokd
 }
 
-sha512sums="780bbb3e7fe37b4a91f222ba5004efbc05f59555779b55c836fda856d5c2db244ee45b61b0f4099219ac8f8b74afa5268e41e9f416b7af441c8de4a0de04af76  wok-2.5.0.tar.gz
+sha512sums="839fe4ac6b4dbeeaa11925e57f7291a2d9609c4c7f420fe1493e77705704908a88bddff883f188498591904ec5fb2119cb62c339ae9e20361139415685432863  wok-2.5.0.tar.gz
 a05554686e0ea2d069a5b9e9b83f6aee678ed299269d86d1192ae417ba98fa8e727d55be8f396360c70846f549f46e64028956e5f7f5c50bbf5601f548c8bd71  wokd.initd
 f257815edbd44baee4a3fbb680a8aa25a9804db1d2ef9326512dc7888c089c212d78e5b2cc7f6e28443dc64b10c7b7f4266e899570bcd2b25bc8bf6b4510a20d  alpine-specific-pushserver.patch
 eb7a9f61d40d7edb11cc451ef25b6b2b920be23ddab7477798592bfe8a2bce8c3be21ac3d75b00d4ed3d2817af779799889fdd906d50039dec00c0c677d2c30c  alpine-specific-wokd.patch"