From b9697c83dec7390f4ce0990d7afa00cddb76a8a2 Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Thu, 9 May 2019 02:30:42 -0300
Subject: [PATCH] community/libevhtp: upgrade to 1.2.18

- Enable regex support with oniguruma

Closes: GH-7715
---
 community/libevhtp/APKBUILD | 24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)

diff --git a/community/libevhtp/APKBUILD b/community/libevhtp/APKBUILD
index 4d3b0deebb86..2a6daef4ae76 100644
--- a/community/libevhtp/APKBUILD
+++ b/community/libevhtp/APKBUILD
@@ -1,31 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
 # Contributor: <xmingske@gmail.com>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=libevhtp
-pkgver=1.2.16
+pkgver=1.2.18
 pkgrel=0
 pkgdesc="Flexible replacement for libevent's httpd API"
+options="!check" # No testsuite
 url="https://github.com/criticalstack/libevhtp/"
 arch="all"
-license="BSD"
-makedepends="cmake libevent-dev openssl-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/criticalstack/libevhtp/archive/$pkgver.tar.gz"
+license="BSD-3-Clause"
+makedepends="cmake libevent-dev openssl-dev oniguruma-dev"
 subpackages="$pkgname-dev"
-
-builddir="${srcdir}/${pkgname}-${pkgver}"
+source="$pkgname-$pkgver.tar.gz::https://github.com/criticalstack/libevhtp/archive/$pkgver.tar.gz"
 
 build() {
-	cd "${builddir}"
-	cmake -DCUSTOM_BINDIR=/usr/bin \
-                -DCMAKE_INSTALL_PREFIX=/usr \
-                -DCUSTOM_DOCDIR="/usr/share/doc/${pkgname}" \
-                -DCUSTOM_SHAREDIR="/usr/share/${pkgname}" \
-                -DEVHTP_BUILD_SHARED=ON .
+	cmake \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DBUILD_SHARED_LIBS=ON
 	make
 }
 
 package() {
-	cd "${builddir}"
 	make DESTDIR="${pkgdir}" install
 }
 
-sha512sums="0beb16a4ffc43fbc6364e456010b581fb55a79f7790ba698a754acb1bb39fb6256e77a3f9ccefe30f6bacd9201d674e31a3c6734fd98d082b35f3105521aff46  libevhtp-1.2.16.tar.gz"
+sha512sums="e01d771a9358fcf912578f34acd235711a3231029b453781f2992cf51cea26aa3f1eb170d3a834f15d4f9b3f37235fb006853eeee509945e2c18e3a7fbb06ae4  libevhtp-1.2.18.tar.gz"
-- 
GitLab