diff --git a/main/xf86-video-rendition/APKBUILD b/main/xf86-video-rendition/APKBUILD
index 7796e673df5c65933a2244a1a8f68b4e5b61190d..d50d1bed1e8022f17a770ecbfcaa21e8ef7dc3a6 100644
--- a/main/xf86-video-rendition/APKBUILD
+++ b/main/xf86-video-rendition/APKBUILD
@@ -8,6 +8,7 @@ arch="all"
 license="custom"
 subpackages="$pkgname-doc"
 depends=
+options="!strip"
 makedepends="xorg-server-dev libxi-dev fontsproto randrproto
 	videoproto renderproto"
 
@@ -29,6 +30,9 @@ build() {
 package() {
 	cd "$srcdir"/$pkgname-$pkgver
 	make DESTDIR="$pkgdir" install || return 1
+
+	# Stripping manually
+	strip $pkgdir/usr/lib/xorg/modules/drivers/rendition_drv.so
 	install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
 }
 md5sums="405dd1acba9c2e43d7aa67b631762495  xf86-video-rendition-4.2.6.tar.bz2"