diff --git a/testing/py3-libevdev/APKBUILD b/testing/py3-libevdev/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..cabe04ba46d535f378a98b04216967d91ede9cd9
--- /dev/null
+++ b/testing/py3-libevdev/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-libevdev
+_pkgname=python-libevdev
+pkgver=0.7
+pkgrel=0
+pkgdesc="Python3 wrapper around the evdev library"
+url="https://python-libevdev.readthedocs.io/en/latest"
+arch="noarch"
+license="MIT"
+depends="libevdev python3"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.freedesktop.org/libevdev/${_pkgname}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	PYTHONPATH=. pytest-3 test/*.py
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7ab4bfcb53c0f84735ad5e7fc8c5bde5b164dd3600d7e8c99fdeea1481f75cc177f67ce875ed14ff93cff43d8037cf5c729abc38d2b9b4f2791ad75d5ad50920  py3-libevdev-0.7.tar.gz"