diff --git a/community/prosody/APKBUILD b/community/prosody/APKBUILD
index fd3148845e2598ea2c764f76488c8a685c250bc7..df6fea0871666f00405d97a02543e5efc36acf12 100644
--- a/community/prosody/APKBUILD
+++ b/community/prosody/APKBUILD
@@ -9,7 +9,7 @@ url="http://prosody.im/"
 arch="all"
 license="MIT"
 depends="lua${_luaver}-socket lua${_luaver}-expat lua${_luaver}-filesystem
-	lua${_luaver}-sec lua${_luaver} lua${_luaver}-busted lua${_luaver}"
+	lua${_luaver}-sec lua${_luaver} lua${_luaver}-busted"
 makedepends="linux-headers lua${_luaver}-dev libidn-dev openssl-dev"
 checkdepends="lua-busted"
 install="prosody.pre-install"
@@ -21,10 +21,7 @@ source="https://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
 	$pkgname.initd
 	"
 
-builddir="$srcdir/$pkgname-$pkgver"
-
 build() {
-	cd "$builddir"
 	./configure \
 		--prefix=/usr \
 		--sysconfdir=/etc/prosody \
@@ -41,12 +38,10 @@ build() {
 }
 
 check() {
-	cd "$builddir"
 	/usr/bin/lua${_luaver} /usr/bin/busted --lua=/usr/bin/lua${_luaver}
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 
 	install -d -o prosody -g prosody "$pkgdir/var/log/prosody"