From 8db25d5fa1aaafe794536ed073f8c6b938c8147f Mon Sep 17 00:00:00 2001
From: Roberto Oliveira <robertoguimaraes8@gmail.com>
Date: Fri, 27 Oct 2017 11:21:05 +0000
Subject: [PATCH] testing/yara: fix test failure

Delete re_lexer.c file to force it to be build with new version
of flex, othwewise tests fail in some arches because of a bug
in older version of flex.

See: https://github.com/VirusTotal/yara/issues/771
---
 testing/yara/APKBUILD | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index a54b0857efed..e660ebabdab7 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -7,11 +7,19 @@ pkgdesc="The pattern matching swiss knife for malware researchers"
 url="https://virustotal.github.io/yara/"
 arch="all"
 license="BSD-3-Clause"
-makedepends="automake file-dev libressl-dev autoconf libtool"
+makedepends="automake file-dev libressl-dev autoconf libtool flex"
 source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/$pkgname/archive/v$pkgver.tar.gz"
 subpackages="$pkgname-doc"
 builddir="$srcdir/$pkgname-$pkgver"
 
+prepare() {
+	default_prepare
+	# Delete re_lexer.c to force it to be build with new version
+	# of flex, othwewise tests fail in some arches because of a bug
+	# in older version of flex.
+	# See: https://github.com/VirusTotal/yara/issues/771
+	rm "$srcdir"/yara-3.6.3/libyara/re_lexer.c
+}
 build() {
 	cd "$builddir"
 	autoreconf -fiv
-- 
GitLab