diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index a54b0857efede4070e91562179d730a6a2bfb82e..e660ebabdab7f0e80c49dcabf1d2721741e07c55 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -7,11 +7,19 @@ pkgdesc="The pattern matching swiss knife for malware researchers"
 url="https://virustotal.github.io/yara/"
 arch="all"
 license="BSD-3-Clause"
-makedepends="automake file-dev libressl-dev autoconf libtool"
+makedepends="automake file-dev libressl-dev autoconf libtool flex"
 source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/$pkgname/archive/v$pkgver.tar.gz"
 subpackages="$pkgname-doc"
 builddir="$srcdir/$pkgname-$pkgver"
 
+prepare() {
+	default_prepare
+	# Delete re_lexer.c to force it to be build with new version
+	# of flex, othwewise tests fail in some arches because of a bug
+	# in older version of flex.
+	# See: https://github.com/VirusTotal/yara/issues/771
+	rm "$srcdir"/yara-3.6.3/libyara/re_lexer.c
+}
 build() {
 	cd "$builddir"
 	autoreconf -fiv