From 8b62f5ad03d135d97f6b213311d0687429d5e221 Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Sat, 18 May 2019 16:36:02 -0300
Subject: [PATCH] testing: remove duplicate dependencies and superfluous
 builddir statements

Closes: GH-7933
---
 testing/enchant2/APKBUILD              | 2 +-
 testing/evolution-data-server/APKBUILD | 3 +--
 testing/evolution/APKBUILD             | 5 ++---
 testing/gnome-latex/APKBUILD           | 2 +-
 testing/gspell/APKBUILD                | 2 +-
 testing/hitch/APKBUILD                 | 5 +----
 testing/libva-utils/APKBUILD           | 8 ++------
 testing/lxd/APKBUILD                   | 2 --
 testing/netsurf/APKBUILD               | 2 +-
 testing/openscap/APKBUILD              | 2 +-
 testing/perl-spreadsheet-xlsx/APKBUILD | 2 +-
 testing/tesseract-git/APKBUILD         | 2 +-
 testing/wok/APKBUILD                   | 2 +-
 13 files changed, 14 insertions(+), 25 deletions(-)

diff --git a/testing/enchant2/APKBUILD b/testing/enchant2/APKBUILD
index e04ab351a855..f58332c161f0 100644
--- a/testing/enchant2/APKBUILD
+++ b/testing/enchant2/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
 license="LGPL-2.1-or-later"
 subpackages="$pkgname-dev $pkgname-doc"
 makedepends="aspell-dev glib-dev dbus-glib-dev hunspell-dev gettext-dev file
-	bash aspell-dev"
+	bash"
 options="!check" # needs unpackaged unittest-cpp
 source="https://github.com/AbiWord/enchant/releases/download/v${pkgver}/enchant-${pkgver}.tar.gz"
 builddir="$srcdir/enchant-$pkgver"
diff --git a/testing/evolution-data-server/APKBUILD b/testing/evolution-data-server/APKBUILD
index 909ad25bd32e..82a404edc724 100644
--- a/testing/evolution-data-server/APKBUILD
+++ b/testing/evolution-data-server/APKBUILD
@@ -11,11 +11,10 @@ options="suid !check"
 depends_dev="libgdata-dev db-dev gcr-dev icu-dev"
 makedepends="$depends_dev gperf flex bison glib-dev gtk+3.0-dev libsecret-dev
 	libsoup-dev libxml2-dev nss-dev sqlite-dev krb5-dev gnu-libiconv-dev
-	openldap-dev libgdata-dev json-glib-dev webkit2gtk-dev libgweather-dev
+	openldap-dev json-glib-dev webkit2gtk-dev libgweather-dev
 	cmake libical-dev libcanberra-dev vala gobject-introspection-dev"
 subpackages="$pkgname-dev $pkgname-lang"
 source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.xz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
 
 prepare() {
 	default_prepare
diff --git a/testing/evolution/APKBUILD b/testing/evolution/APKBUILD
index 795e78c264af..ceecaf5a9820 100644
--- a/testing/evolution/APKBUILD
+++ b/testing/evolution/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: 
+# Contributor:
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=evolution
 pkgver=3.32.2
@@ -12,11 +12,10 @@ depends="highlight gsettings-desktop-schemas"
 depends_dev="itstool libxml2-dev gcr-dev enchant-dev libcanberra-dev
 	libgweather-dev openldap-dev libnotify-dev"
 makedepends="$depends_dev gperf flex bison libxml2-utils glib-dev
-	webkit2gtk-dev gtkspell3-dev evolution-data-server-dev glib-dev
+	webkit2gtk-dev gtkspell3-dev evolution-data-server-dev
 	gtk+3.0-dev nss-dev cmake gnu-libiconv-dev gsettings-desktop-schemas-dev"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
 source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
 
 build() {
 	mkdir -p "$builddir"/build
diff --git a/testing/gnome-latex/APKBUILD b/testing/gnome-latex/APKBUILD
index 386a74811bff..e9b6a4c37ee3 100644
--- a/testing/gnome-latex/APKBUILD
+++ b/testing/gnome-latex/APKBUILD
@@ -10,7 +10,7 @@ license="GPL-3.0-or-later"
 depends="texlive"
 makedepends="glib-dev intltool itstool vala yelp gobject-introspection-dev
 	gsettings-desktop-schemas-dev gspell-dev gtk+3.0-dev libgee-dev
-	gtksourceview4-dev tepl-dev gspell-dev dconf-dev"
+	gtksourceview4-dev tepl-dev dconf-dev"
 subpackages="$pkgname-doc $pkgname-lang"
 source="https://download.gnome.org/sources/gnome-latex/${pkgver%.*}/gnome-latex-${pkgver}.tar.xz"
 
diff --git a/testing/gspell/APKBUILD b/testing/gspell/APKBUILD
index 5c7f92b3bdf0..c270ddb876b8 100644
--- a/testing/gspell/APKBUILD
+++ b/testing/gspell/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Flexible API to add spell checking to a GTK+ application"
 url="https://wiki.gnome.org/Projects/gspell"
 arch="all"
 license="LGPL-2.1-or-later"
-makedepends="glib-dev vala iso-codes-dev gtk+3.0-dev enchant2-dev vala
+makedepends="glib-dev vala iso-codes-dev gtk+3.0-dev enchant2-dev
 	gobject-introspection-dev"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
 options="!check" # Needs DISPLAY
diff --git a/testing/hitch/APKBUILD b/testing/hitch/APKBUILD
index 885640ecdf57..2bab4eb11da3 100644
--- a/testing/hitch/APKBUILD
+++ b/testing/hitch/APKBUILD
@@ -8,19 +8,17 @@ url="https://hitch-tls.org/"
 arch="all"
 license="BSD"
 makedepends="libev-dev openssl-dev automake autoconf py-docutils bison flex
-	autoconf automake libtool"
+	libtool"
 subpackages="$pkgname-doc"
 source="https://hitch-tls.org/source/hitch-$pkgver.tar.gz
 	disable-Werror.patch"
 
-builddir="$srcdir"/$pkgname-$pkgver
 prepare() {
 	default_prepare
 	autoreconf -vif -I.
 }
 
 build() {
-	cd "$builddir"
 	./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -32,7 +30,6 @@ build() {
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 }
 sha512sums="4225391822c6e223e795bbc4756d55dcd8d16f61b42cf1e336205ae0707c1ba1f86b4c0be1457695d0f0ad4ec1906fdacb46cdd0dbbe50d00385380a9cbad617  hitch-1.4.8.tar.gz
diff --git a/testing/libva-utils/APKBUILD b/testing/libva-utils/APKBUILD
index 64a50fd14a32..34b074a53be6 100644
--- a/testing/libva-utils/APKBUILD
+++ b/testing/libva-utils/APKBUILD
@@ -7,13 +7,11 @@ pkgdesc="Intel VA-API Media Applications and Scripts for libva"
 url="https://github.com/01org/libva-utils"
 arch="all"
 license="MIT"
-makedepends="mesa-dev libva-dev autoconf automake libtool libva-dev"
+makedepends="mesa-dev libva-dev autoconf automake libtool"
 source="https://github.com/01org/libva-utils/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
 options="!check"
-builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
-	cd "$builddir"
 	 ./autogen.sh \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -26,13 +24,11 @@ build() {
 	make
 }
 
-check(){
-	cd "$builddir"
+check() {
 	make check
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 }
 
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
index a4935aed35ec..c94adad2b3c8 100644
--- a/testing/lxd/APKBUILD
+++ b/testing/lxd/APKBUILD
@@ -25,7 +25,6 @@ makedepends="
 	lxc-dev
 	gettext-dev
 	acl-dev
-	libuv-dev
 	tcl-dev
 	libuv-dev
 	libcap-dev
@@ -61,7 +60,6 @@ sonameprefix="$pkgname:"
 
 _project="github.com/lxc/lxd"
 
-builddir="$srcdir"/lxd-$pkgver
 
 prepare() {
 	default_prepare
diff --git a/testing/netsurf/APKBUILD b/testing/netsurf/APKBUILD
index 2ff9cb8a3253..121cfef072ca 100644
--- a/testing/netsurf/APKBUILD
+++ b/testing/netsurf/APKBUILD
@@ -12,7 +12,7 @@ depends=""
 depends_dev=""
 makedepends="curl-dev openssl-dev doxygen flex bison libwebp-dev lcms2-dev
 	libmng-dev gperf libglade-dev gtk+-dev libcurl libpng-dev libidn-dev
-	check-dev libidn-dev libharu-dev librsvg-dev libjpeg-turbo-dev"
+	check-dev libharu-dev librsvg-dev libjpeg-turbo-dev"
 install=""
 subpackages="$pkgname-doc"
 source="$pkgname-$pkgver.tar.gz::http://download.netsurf-browser.org/netsurf/releases/source-full/$pkgname-all-$pkgver.tar.gz
diff --git a/testing/openscap/APKBUILD b/testing/openscap/APKBUILD
index 2ec1fd9ddfc4..41bef159898f 100644
--- a/testing/openscap/APKBUILD
+++ b/testing/openscap/APKBUILD
@@ -11,7 +11,7 @@ makedepends="cmake python3-dev dbus-dev dbus-glib-dev bash libselinux-dev
 curl-dev openssl-dev libgcrypt-dev acl-dev libblkid libcap-dev libxml2-dev 
 libxslt-dev openldap-dev pcre2-dev perl-xml-parser perl-xml-xpath perl-dev 
 rpm-dev swig bzip2-dev gconf-dev asciidoc fts-dev doxygen procps-dev
-libbz2 util-linux-dev perl-dev nss-dev"
+libbz2 util-linux-dev nss-dev"
 options="!check"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
 source="https://github.com/OpenSCAP/openscap/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
diff --git a/testing/perl-spreadsheet-xlsx/APKBUILD b/testing/perl-spreadsheet-xlsx/APKBUILD
index d9888a07fdeb..c3aaba82a687 100644
--- a/testing/perl-spreadsheet-xlsx/APKBUILD
+++ b/testing/perl-spreadsheet-xlsx/APKBUILD
@@ -10,7 +10,7 @@ url="https://metacpan.org/release/Spreadsheet-XLSX/"
 arch="noarch"
 license="GPL PerlArtistic"
 cpandepends="perl-spreadsheet-parseexcel perl-archive-zip perl-test-nowarnings"
-depends="perl-spreadsheet-parseexcel $cpandepends"
+depends="$cpandepends"
 makedepends="perl-dev perl-spreadsheet-parseexcel"
 subpackages="$pkgname-doc"
 source="https://cpan.metacpan.org/authors/id/M/MI/MIKEB/Spreadsheet-XLSX-$pkgver.tar.gz"
diff --git a/testing/tesseract-git/APKBUILD b/testing/tesseract-git/APKBUILD
index a749d1692f67..cd4c53d0a0b7 100644
--- a/testing/tesseract-git/APKBUILD
+++ b/testing/tesseract-git/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
 license="Apache-2.0"
 depends=""
 makedepends="cmake leptonica-dev tiff-dev icu-dev cairo-dev automake autoconf
-	libtool autoconf-archive pango-dev cairo-dev"
+	libtool autoconf-archive pango-dev"
 install=""
 replaces="tesseract-ocr"
 subpackages="$pkgname-dev $pkgname-training"
diff --git a/testing/wok/APKBUILD b/testing/wok/APKBUILD
index bc0947b57a73..e809a953dcd5 100644
--- a/testing/wok/APKBUILD
+++ b/testing/wok/APKBUILD
@@ -9,7 +9,7 @@ arch="noarch"
 license="Apache LGPL-2.1"
 depends="python2 nginx logrotate py-cherrypy py2-jsonschema
 	py2-pyparted  py2-pyldap py2-psutil py2-m2crypto py-cheetah
-	py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt py-cherrypy
+	py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt
 	ttf-opensans ttf-font-awesome"
 makedepends="automake autoconf libtool gettext-dev
 	python2-dev pyflakes libxslt py-setuptools py2-websockify py2-mock"
-- 
GitLab