diff --git a/community/ices/APKBUILD b/community/ices/APKBUILD
index c38b8aba374966d7a8f18d54b07e8737e748d32f..89c08106db96f24d1d82c432647ee9bd00f4fce6 100644
--- a/community/ices/APKBUILD
+++ b/community/ices/APKBUILD
@@ -7,21 +7,18 @@ pkgdesc="Source client for broadcasting in MP3 format to an icecast2 server"
 url="http://icecast.org/ices.php"
 arch="all"
 license="GPL-2.0-or-later"
-depends=""
 makedepends="libogg-dev libxml2-dev libvorbis-dev libshout-dev alsa-lib-dev
-			lame-dev perl-dev python2-dev libxml2-dev linux-headers"
+	lame-dev perl-dev python2-dev linux-headers"
 subpackages="$pkgname-doc"
 source="http://downloads.us.xiph.org/releases/ices/$pkgname-$pkgver.tar.gz"
 replaces="ices2"
-builddir=$srcdir/$pkgname-$pkgver
 
 prepare() {
-	default_prepare || return 1
-	update_config_guess || return 1
+	default_prepare
+	update_config_guess
 }
 
 build() {
-	cd "$builddir"
 	./configure \
 		--prefix=/usr \
 		--datadir=/usr/share/doc/ \
@@ -29,15 +26,13 @@ build() {
 		--with-lame \
 		--with-vorbis \
 		--with-python \
-		--with-perl \
-		|| return 1
-	make || return 1
+		--with-perl
+	make
 }
 
 package() {
-	cd "$builddir"
-	make DESTDIR="$pkgdir" install || return 1
-	make -C conf DESTDIR="$pkgdir" install || return 1
+	make DESTDIR="$pkgdir" install
+	make -C conf DESTDIR="$pkgdir" install
 }
 
 md5sums="d2f53320ebc7b468d0e0f8a3d2b70883  ices-2.0.2.tar.gz"