diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 83432cadc77b6317c480cd91aba03fc15d55ee25..610360a9a41ac38027f41240d25536b777ac964f 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=bluez
 pkgver=5.50
-pkgrel=0
+pkgrel=1
 pkgdesc="Tools for the Bluetooth protocol stack"
 url="http://www.bluez.org/"
 arch="all"
@@ -10,7 +10,7 @@ depends="consolekit2 dbus"
 replaces="udev"
 makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
 	libical-dev readline-dev glib-dev linux-headers
-	autoconf automake libtool libell-dev"
+	autoconf automake libtool ell-dev"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmon $pkgname-cups
 	$pkgname-deprecated $pkgname-hid2hci $pkgname-meshctl $pkgname-obexd"
 source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
diff --git a/main/libell/APKBUILD b/main/libell/APKBUILD
deleted file mode 100644
index 2093bf19cb91cbc9587e19b0dd4a4d827a5ef0e3..0000000000000000000000000000000000000000
--- a/main/libell/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: Pedro Filipe <xpecex@outlook.com>
-pkgname=libell
-pkgver=0.17
-pkgrel=0
-pkgdesc="The Embedded Linux* Library (ELL) provides core, low-level functionality for system daemons."
-url="https://01.org/ell"
-arch="all"
-license="GPL-2.1"
-makedepends="libnl3-dev dbus linux-headers"
-subpackages="$pkgname-dev"
-source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/ell-$pkgver.tar.xz
-	fix-WAIT_ANY-test-dbus.patch
-	"
-builddir="$srcdir/ell-$pkgver"
-options="!check" # testsuite shows unknown error in unit/test-cipher
-
-build() {
-	cd "$builddir"
-	./configure \
-		--build=$CBUILD \
-		--host=$CHOST \
-		--prefix=/usr \
-		--sysconfdir=/etc \
-		--mandir=/usr/share/man \
-		--infodir=/usr/share/info \
-		--localstatedir=/var
-	make
-}
-
-package() {
-	cd "$builddir"
-	make DESTDIR="$pkgdir" install
-}
-
-sha512sums="5ca82bf3dbfacb7770fe1132ec3d93d7ebd139f1781157f1def8d810b21c84b212c555c981f7b80152e49e0da0a82b46fbd6322aadc25c56f26c21065a8886ef  ell-0.17.tar.xz
-456f49b0f9c5ff93b1af2221d59f224b7b61847360e3f25b0d42af733fc4b296d30bb50349e00437c6e235c0bacba74c1a5b502dcc1b0c4bdbc38f101b3d4220  fix-WAIT_ANY-test-dbus.patch"
diff --git a/main/libell/fix-WAIT_ANY-test-dbus.patch b/main/libell/fix-WAIT_ANY-test-dbus.patch
deleted file mode 100644
index 27c86eaa6665057852c05393b4e4985329a7d874..0000000000000000000000000000000000000000
--- a/main/libell/fix-WAIT_ANY-test-dbus.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/unit/test-dbus.c
-+++ b/unit/test-dbus.c
-@@ -32,6 +32,10 @@
- 
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
- 
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- static pid_t dbus_daemon_pid = -1;
- 
- static void start_dbus_daemon(void)
-
-
---- a/unit/test-dbus-message-fds.c
-+++ b/unit/test-dbus-message-fds.c
-@@ -37,6 +37,10 @@
- 
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
- 
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- static pid_t dbus_daemon_pid = -1;
- 
- static bool start_dbus_daemon(void)
-
-
---- a/unit/test-dbus-properties.c
-+++ b/unit/test-dbus-properties.c
-@@ -34,6 +34,10 @@
- 
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
- 
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- static pid_t dbus_daemon_pid = -1;
- 
- static bool start_dbus_daemon(void)
-