diff --git a/community/wine/APKBUILD b/community/wine/APKBUILD
index e665901ad00bce18271003a97cb1cec00729b354..b5e79037ece58916c7d1ac1dc7da1cdbef3e956c 100644
--- a/community/wine/APKBUILD
+++ b/community/wine/APKBUILD
@@ -7,7 +7,7 @@
 pkgname=wine
 pkgver=4.0.1
 _pkgver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
 pkgdesc="A compatibility layer for running Windows programs"
 url="https://www.winehq.org"
 arch="x86 x86_64"
@@ -20,6 +20,7 @@ makedepends="alsa-lib-dev autoconf automake bison cups-dev dbus-dev flex-dev
 	libxcomposite-dev libxcursor-dev libxdamage-dev libxi-dev libxinerama-dev
 	libxml2-dev libxrandr-dev libxrender-dev libxslt-dev libxxf86dga-dev mesa-dev
 	ncurses-dev openldap-dev openssl-dev tiff-dev udisks2-dev v4l-utils-dev zlib-dev
+	vulkan-loader-dev vkd3d-dev
 	"
 checkdepends="xvfb-run"
 source="https://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$_pkgver.tar.xz
@@ -27,7 +28,6 @@ source="https://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$_pkgver
 	wine-dlclose-bug41703.patch
 	winhlp32-flex.patch
 	"
-builddir="$srcdir/$pkgname-$_pkgver"
 
 prepare() {
 	default_prepare
@@ -47,6 +47,8 @@ build() {
 		--localstatedir=/var \
 		--with-dbus \
 		--with-x \
+		--with-vkd3d \
+		--with-vulkan \
 		$_win64
 	make
 }