From 60ffb9bf70fb61cdd060a2d3d3ca7b7d9bcfd152 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Tue, 24 Jul 2018 14:23:35 +0000
Subject: [PATCH] testing/py3-texttable: new aport

module for creating simple ASCII tables
https://github.com/foutaise/texttable/
---
 testing/py3-texttable/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/py3-texttable/APKBUILD

diff --git a/testing/py3-texttable/APKBUILD b/testing/py3-texttable/APKBUILD
new file mode 100644
index 000000000000..c58340e34c14
--- /dev/null
+++ b/testing/py3-texttable/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-texttable
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="module for creating simple ASCII tables"
+url="https://github.com/foutaise/texttable/"
+arch="all"
+license="LGPL-3.0"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
+builddir="$srcdir/texttable-$pkgver"
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py check
+}
+
+package() {
+	cd "$builddir"
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5  texttable-1.4.0.tar.gz"
-- 
GitLab