diff --git a/community/audacity/APKBUILD b/community/audacity/APKBUILD
index 23aa2168d53645a089a5aad063153d094e86cbd1..9f36f3113105c47c146e90a19e0db597598b0a37 100644
--- a/community/audacity/APKBUILD
+++ b/community/audacity/APKBUILD
@@ -1,13 +1,13 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=audacity
-pkgver=2.1.1
-pkgrel=1
+pkgver=2.3.2
+pkgrel=0
 pkgdesc="Multitrack audio editor"
-url="http://audacity.sourceforge.net"
+url="https://www.audacityteam.org/"
 arch="all"
-license="GPL-2.0"
-makedepends="$depends_dev
+license="GPL-2.0-or-later"
+makedepends="
 	alsa-lib-dev
 	bash
 	expat-dev
@@ -19,67 +19,58 @@ makedepends="$depends_dev
 	libogg-dev
 	libsndfile-dev
 	libvorbis-dev
-	portaudio-dev
 	soundtouch-dev
 	soxr-dev
 	taglib-dev
-	wxgtk2.8-dev
+	wxgtk3-dev
+	ffmpeg-dev
+	automake
+	autoconf
+	libtool
 	"
-
 subpackages="$pkgname-doc $pkgname-lang"
 source="https://github.com/audacity/audacity/archive/Audacity-$pkgver.tar.gz
-	musl-workaround.patch
-	filedialog.patch
 	"
 
 builddir="$srcdir"/audacity-Audacity-$pkgver
 
+prepare() {
+	default_prepare
+	autoreconf -fi
+}
+
 build() {
 	local _arch
 
-	cd "$builddir"
-
 	case "$CTARGET" in
-	x86|x86_64) _arch="--enable-sse";;
-	*) _arch="--disable-sse";;
+		x86|x86_64) _arch="--enable-sse";;
+		*) _arch="--disable-sse";;
 	esac
-	export CXXFLAGS="$CXXFLAGS -std=gnu++98"
-	LIBNYQUIST_USE_LOCAL=yes \
-	CFLAGS="$CFLAGS -fPIC" \
-	./configure \
-		--build=$CBUILD \
-		--host=$CHOST \
-		--prefix=/usr \
-		--sysconfdir=/etc \
-		--mandir=/usr/share/man \
-		--with-expat=system \
-		--with-lib-preference=system \
-		--with-libsndfile=system \
-		--with-libflac=system \
-		--with-coundtouch=system \
-		--with-soxr=system \
-		--with-id3tag=system \
-		--with-libvorbis=system \
-		--with-portaudio=system \
-		--with-libmad=system \
-		--with-widgetextra=local \
-		--without-libresample \
-		--without-libsamplerate \
-		--without-ffmpeg \
-		--enable-nyquist \
-		$_arch
 
-	for i in ffmpeg libsoxr libvamp portaudio-v19; do
-		rm -r lib-src/$i
-	done
+	WX_CONFIG=wx-config-gtk3 \
+	bash configure \
+		--prefix="/usr" \
+		--with-libsndfile="system" \
+		--with-ffmpeg="system" \
+		--with-expat="system" \
+		--with-lame="system" \
+		--with-libsoxr="system" \
+		--with-portaudio \
+		--with-portmidi \
+		--with-libflac \
+		--with-libid3tag \
+		--with-libsamplerate \
+		--with-sbsms \
+		--with-soundtouch \
+		--with-libtwolame \
+		--with-libvorbis \
+		--without-lv2 \
+		$_arch
 	make
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="00b0a037ffefb670e7148414224c60330c4fb915a892cb635537caeba82815d0113c5bb07f7b2805ed9b42a1a75106ef6fdc2f1602fd5042c48cc5e111a34ffb  Audacity-2.1.1.tar.gz
-b5488a7f5398c07fe986e090b8d61353ecba594ed23fda6a4444e59718f7d1e8bd5c716047ce139350983d5609b5810362a78a2fd5d85e9b1730d196c57c685b  musl-workaround.patch
-7f10b5f53ada9faa7ad887400a5729a41228f8970ee4cc045291e9b203a9f7f068b09f709e23f7f2a15724acf82ed0e4bccfd163b2232b430d2c89b86ccc2751  filedialog.patch"
+sha512sums="a59d6e9e974d5f78f5ca561e3bea31fc1b3e88f9ea60b2df7ce8bcec264d886f3fdc8f20030e11a86daff8ffeb735850b5e5f73c45fbef0bfcc58692423e7cd0  Audacity-2.3.2.tar.gz"
diff --git a/community/audacity/filedialog.patch b/community/audacity/filedialog.patch
deleted file mode 100644
index 0232c5619dc4d1f6b95190164028ac9eeb19c779..0000000000000000000000000000000000000000
--- a/community/audacity/filedialog.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib-src/FileDialog/generic/FileDialogPrivate.cpp b/lib-src/FileDialog/generic/FileDialogPrivate.cpp
-index 315a4cb..baa2e60 100644
---- a/lib-src/FileDialog/generic/FileDialogPrivate.cpp
-+++ b/lib-src/FileDialog/generic/FileDialogPrivate.cpp
-@@ -392,7 +392,7 @@ void FileData::MakeItem( wxListItem &item )
-    if (IsLink())
-    {
-       wxColour dg = wxTheColourDatabase->Find( wxT("MEDIUM GREY") );
--      if ( dg.Ok() )
-+      if ( dg.IsOk() )
-          item.SetTextColour(dg);
-    }
-    item.m_data = (long)this;
diff --git a/community/audacity/musl-workaround.patch b/community/audacity/musl-workaround.patch
deleted file mode 100644
index ababf9036671d76f5708fec5249a8c8b168c5a8b..0000000000000000000000000000000000000000
--- a/community/audacity/musl-workaround.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The use of RTLD_DEEPBIND is just a workaround and not a real fix.
-And we cannot use it...
-
---- ./src/effects/VST/VSTEffect.cpp.orig
-+++ ./src/effects/VST/VSTEffect.cpp
-@@ -2609,6 +2609,10 @@
-    // symbols.
-    //
-    // Once we define a proper external API, the flags can be removed.
-+// GNU extension
-+#ifndef RTLD_DEEPBIND
-+#define RTLD_DEEPBIND 0
-+#endif
-    void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL | RTLD_DEEPBIND);
-    if (!lib) 
-    {