diff --git a/community/thunar/APKBUILD b/community/thunar/APKBUILD
index ec7b929bb7cb100c87fb7a9d9f8ab34fe48f9201..05b3165f38710fa37933bad8f5ae2bbd28e25066 100644
--- a/community/thunar/APKBUILD
+++ b/community/thunar/APKBUILD
@@ -1,10 +1,10 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=thunar
-pkgver=1.8.6
+pkgver=1.8.7
 pkgrel=0
 pkgdesc="File manager for Xfce"
 url="https://xfce.org"
-arch="all"
+arch="all !x86" # Limited by webkit2gtk
 license="GPL-2.0-or-later LGPL-2.0-only"
 depends="desktop-file-utils hicolor-icon-theme shared-mime-info"
 depends_dev="exo-dev"
@@ -20,7 +20,6 @@ source="https://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar
 builddir="$srcdir"/Thunar-$pkgver
 
 prepare() {
-	cd "$builddir"
 	# fix icon in thunar-sendto-email.desktop
 	sed -i 's!internet-mail!mail-message-new!' \
 		plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
@@ -28,7 +27,6 @@ prepare() {
 }
 
 build() {
-	cd "$builddir"
 	./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -47,12 +45,10 @@ build() {
 }
 
 check() {
-	cd "$builddir"
 	make check
 }
 
 package() {
-	cd "$builddir"
 	local f
 	make DESTDIR="$pkgdir" install
 	sed -i -e 's:x-directory/gnome-default-handler;::' \
@@ -67,6 +63,6 @@ package() {
 	done
 }
 
-sha512sums="086dc139627d8f11341b2db91358ef1831d2b8494d34abac49355dbaf850a21c30f979294f9adf2bc8548e5f817a4e165803a3db74cd989cd3867a4e228d74db  Thunar-1.8.6.tar.bz2
+sha512sums="d4faf28857ee7c29c799bec9c5d7c639596b213f2aeb1089125d074083a4a13e91425cf3f35c63ce313330ee9ef070653a868a1a4526dc443a5d603bd9dec588  Thunar-1.8.7.tar.bz2
 dce525f22abf8e723111673b8fdad48079d5379cef49cc013383bb0944274cdd0de1dda6e8894dd8c9efb54cc9eea2baf8f4c76265665b84f3f58aeb01c72390  thunar-sendto-audacious-playlist.desktop
 b4e8024e093b8e3f9bf5d460335fd9d19c1e394383bd58a7ac05c720103612dea9dde8a02f090f0af09d89e6644b292236ef257dd1790eccd627efce0577828e  thunar-sendto-bluetooth.desktop"