From 4411b1b5f2ea69dccfa3825904b66c7a0e5bcdb6 Mon Sep 17 00:00:00 2001
From: Leonardo Arena <rnalrd@alpinelinux.org>
Date: Mon, 3 Jun 2019 13:32:36 +0000
Subject: [PATCH] testing/py3-fakeredis: new aport

Fake implementation of redis API for testing purposes
---
 testing/py3-fakeredis/APKBUILD | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-fakeredis/APKBUILD

diff --git a/testing/py3-fakeredis/APKBUILD b/testing/py3-fakeredis/APKBUILD
new file mode 100644
index 000000000000..245fe0417339
--- /dev/null
+++ b/testing/py3-fakeredis/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-fakeredis
+_pkgname=${pkgname#py3-}
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Fake implementation of redis API for testing purposes"
+url="https://pypi.org/project/fakeredis/"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3-dev"
+checkdepends="py3-redis py3-six py3-nose py3-sortedcontainers py3-lupa"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	PYTHONPATH=. python3 test_fakeredis.py
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8e91b1d6bd08816d20d313ae234f59f974655026cb52ae27c42ee7cb540855206f37fd6ccbe12ebfc07ebdf737f473217a934a80657f720db0053ebdf735cf99  py3-fakeredis-1.0.3.tar.gz"
-- 
GitLab