From 212df81b24ed85e6c24faccf338b08bb73739f4b Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 17 Apr 2019 14:54:19 +0000
Subject: [PATCH] main/py-six: disable test to fix circular deps with pytest

---
 main/py-six/APKBUILD | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index 18c3b0f0e49f..856271679a28 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -7,17 +7,15 @@ pkgdesc="Python 2 and 3 compatibility library"
 url="https://pypi.python.org/pypi/six"
 arch="noarch"
 license="MIT"
-checkdepends="pytest py3-pytest"
 _py2_deps="py-enum34"
 makedepends="python2-dev python3-dev py2-setuptools py3-setuptools $_py2_deps"
 subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
 source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
-if [ -n "$BOOTSTRAP" ]
-then
-	# circular dependency with pytest
-	options="!check"
-fi
+
+# circular dependency with pytest
+#checkdepends="pytest py3-pytest"
+options="!check"
 
 build() {
 	python2 setup.py build
-- 
GitLab