Commit 90eddd0e authored by prspkt's avatar prspkt Committed by Leo

main/mesa: upgrade to 20.1.4

* Remove patch for missing dependency on sha1, fix is now upstream.
parent 06adc31a
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=20.1.3
pkgver=20.1.4
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="https://www.mesa3d.org"
......@@ -63,7 +63,6 @@ source="
adjust-cache-deflate-buffer.patch
musl-fix-includes.patch
add-use-elf-tls.patch
missing-dep-on-sha1_h.patch
disable-rgb10-by-default.patch
"
replaces="mesa-dricore"
......@@ -326,9 +325,8 @@ _vulkan_layer() {
mv "$pkgdir"/usr/bin/mesa-overlay-control.py "$subpkgdir"/usr/bin
}
sha512sums="c3134cda6a07041c2cacd783663c0618e97f907bb0e67718a5c8fb03f4608ba47f0cd5adb6f0400a44f15fd70f3b41d66da1376035ba4e4f4f97a1843dcb1f77 mesa-20.1.3.tar.xz
sha512sums="f4d79694cda8531e7560147caf5d18bce5c685cd6c61264dced5adaa9043be9c83d3a2bd623ebffedc8d4258b9b1f97d84d9aeea307aa77cf99d0bc47c987155 mesa-20.1.4.tar.xz
cdf22d2da3328e116c379264886bd01fd3ad5cc45fe03dc6fd97bdc4794502598ee195c0b9d975fa264d6ac31c6fa108c0535c91800ecf4fcabfd308e53074cc adjust-cache-deflate-buffer.patch
cf849044d6cc7d2af4ff015208fb09d70bf9660538699797da21bda2ecb7c1892d312af83d05116afd826708d9caafb1d05a13f09139c558aea6fee931e3eee7 musl-fix-includes.patch
cd3961319079882e692176f654feb21ddfeccafcc7f4ce4f8d21160f36deda768eb3ee7f49dae2e18f0587d321473adc7f127a2d75ae143ec29168bcc0fe12c0 add-use-elf-tls.patch
250a048193d1e2f4044c6850e707e1b0f67812f03357cb53bc4c3c501ade14dc9b0f40bf6a7d87903a65d5d87af58d210fd2729fa658f10b63d4d2d60b6bcc11 missing-dep-on-sha1_h.patch
ede642ae9be64c3fc5fee46e8bf1b2f982191febcfadb235b0261868213c7cca11d38bb53b972f3184a887430f37b9f470a9b12fd03cf54b98315ec75c4d8ed4 disable-rgb10-by-default.patch"
diff --git a/src/vulkan/overlay-layer/meson.build b/src/vulkan/overlay-layer/meson.build
index 5b553d0..51e053e 100644
--- a/src/vulkan/overlay-layer/meson.build
+++ b/src/vulkan/overlay-layer/meson.build
@@ -38,7 +38,7 @@ vklayer_files = files(
vklayer_mesa_overlay = shared_library(
'VkLayer_MESA_overlay',
- vklayer_files, overlay_spv,
+ [vklayer_files, sha1_h], overlay_spv,
c_args : [c_vis_args, no_override_init_args, vulkan_wsi_args],
cpp_args : [cpp_vis_args, vulkan_wsi_args],
dependencies : [idep_vulkan_util, idep_mesautil, vulkan_wsi_deps, libimgui_core_dep, dep_dl],
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment