Commit de94e8c5 authored by Leo's avatar Leo Committed by Andy Postnikov
Browse files

community/synapse: upgrade to 1.23.0

parent 9be6d272
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=synapse
pkgver=1.22.1
pkgver=1.23.0
pkgrel=0
pkgdesc="Matrix reference homeserver"
options="!check" # Requires 'py3-hiredis' which needs a rebuild
......@@ -51,6 +51,7 @@ pkggroups="synapse"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/synapse/archive/v$pkgver.tar.gz
relax-prometheus.patch
synapse.initd
synapse.confd
"
......@@ -81,6 +82,7 @@ package() {
install -Dm644 "$srcdir"/synapse.confd "$pkgdir"/etc/conf.d/synapse
}
sha512sums="e640abf6d8a5f901b4f4d047a327085844c0c3306a71b57084905bde4b4a5ff09c1784ff3e69479dda6f6d1cc909ea682ec7a2e975dcab2ba5d90e3c84b25519 synapse-1.22.1.tar.gz
sha512sums="5ebb65ca84816b0117cdff96a24d0b8c9bc7676817d42516b2aa3b0cea70d4a00d88e7ef525f3eece168bf26091b05c88a6f3a2545073994778d6a00e40126f5 synapse-1.23.0.tar.gz
6096dcad8d88bddbe55b8722c33dba7276150691d8b538b78ed222b54f004717f3c401d918410054555e53901213ee5327be0953bc633c00d365b7053b5c5f3c relax-prometheus.patch
4fa4a7bdd80e3b1af0f546723a64cec3b6014c5d52cfb296c41e831f73f72489bd90a3938831c0fd25cdcb03b6e27b54dfd222e325fb30525c39f5c6996687ff synapse.initd
7c022f0e00c8ac363d6d2e003b6389fb06a3934f68390ebac156cb46bc1366585e6b6cda07b15176bc62a00f5bf21bfda153ff5418b07331257a7075102a6f83 synapse.confd"
Upstream: No
Reason: Fixes starting with our py3-prometheus-client
diff --git a/synapse/python_dependencies.py b/synapse/python_dependencies.py
index aab77fc..7ba2220 100644
--- a/synapse/python_dependencies.py
+++ b/synapse/python_dependencies.py
@@ -76,7 +76,7 @@ REQUIREMENTS = [
# Note that we replicate these constraints in the Synapse Dockerfile while
# pre-installing dependencies. If these constraints are updated here, the
# same change should be made in the Dockerfile.
- "prometheus_client>=0.4.0,<0.9.0",
+ "prometheus_client>=0.4.0,<1.0.0",
# we use attr.validators.deep_iterable, which arrived in 19.1.0 (Note:
# Fedora 31 only has 19.1, so if we want to upgrade we should wait until 33
# is out in November.)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment