Commit 68dca958 authored by Natanael Copa's avatar Natanael Copa
Browse files

testing/kine: upgrade to 0.5.1

Also strip elf symbols and debugging

Add provides for virtual etcd-api so other packages can depende on
either etcd or kine.
parent 005d991c
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kine
pkgver=0.4.0
pkgver=0.5.1
pkgrel=0
pkgdesc="etcd API with sqlite, Postgres, Mysql, or dqlite backed"
url="https://github.com/rancher/kine"
......@@ -10,9 +10,10 @@ makedepends="sqlite-dev go"
subpackages="$pkgname-doc"
options="!check" # no testsuite
source="$pkgname-$pkgver.tar.gz::https://github.com/rancher/kine/archive/v$pkgver.tar.gz"
provides="etcd-api"
build() {
go build -v .
go build -v -ldflags="-w -s" .
}
package() {
......@@ -20,4 +21,4 @@ package() {
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/kine/LICENSE
}
sha512sums="affc5074434667bda0fa1e29fdcdcef8b1aee2f330fd1415b6e01e2e1548c033b00006119ecdca89a1b58e0616d171d37b04faf68fc71c70a27c0994717f7322 kine-0.4.0.tar.gz"
sha512sums="0eb5bbfd473fc0a656f0592e655fffd23b83277c3d1f3e6e338f2362b1e168dbf497c503f013a4b56cf2bd1fe5b95f74024ee53bc452765799cc903c12a2df59 kine-0.5.1.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment