From 46aed95754ebeb17a3a367b3b41d0b6424fd18d9 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Fri, 23 Oct 2009 16:53:13 +0000
Subject: [PATCH] abuild: minor cleanup

---
 buildrepo.in | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/buildrepo.in b/buildrepo.in
index c211789714b4..d719c347df00 100755
--- a/buildrepo.in
+++ b/buildrepo.in
@@ -22,9 +22,9 @@ usage() {
 
 
 listpackages() {
-	cd "$aportsdir/$1"
 	for i in */APKBUILD; do
-		APKBUILD=$i abuild listpkg
+		cd "$aportsdir"/$1/${i%/*} 
+		abuild listpkg
 	done
 }
 
-- 
GitLab