diff --git a/community/mpir/APKBUILD b/community/mpir/APKBUILD
index fc864c387667caa3a1a865bbb14545310dd72b92..98c6f5b68a1cdb76451ad2754607acc9f451aecc 100644
--- a/community/mpir/APKBUILD
+++ b/community/mpir/APKBUILD
@@ -2,11 +2,10 @@
 # Maintainer: Marian Buschsieweke <marian.buschsieweke@posteo.net>
 pkgname=mpir
 pkgver=3.0.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Multiple Precision Integers and Rationals"
 url="https://github.com/wbhart/mpir"
-# ppc64le: ABI version 1 is not compatible with ABI version 2 output
-arch="all !ppc64le"
+arch="all"
 license="LGPL-3.0-or-later"
 makedepends="autoconf automake texinfo libtool yasm m4"
 subpackages="$pkgname-dev $pkgname-doc"
@@ -32,10 +31,15 @@ prepare() {
 }
 
 build() {
-	./configure \
-		--prefix=/usr \
-		--enable-cxx \
-		--disable-static
+	local _configure_opts="--prefix=/usr --enable-cxx --disable-static"
+
+	# Add host flag to omit ppc64 ABIv1 assembly code and resolve the error:
+	# ABI version 1 is not compatible with ABI version 2 output
+	if [ "$CARCH" = "ppc64le" ]; then
+		_configure_opts="$_configure_opts --host=none-alpine-linux-musl"
+	fi
+
+	./configure $_configure_opts
 	make
 }