Commit 297cb415 authored by Bart Ribbers's avatar Bart Ribbers Committed by Leo

testing/latte-dock: upgrade to 0.9.2 and add missing runtime dependency

parent 6aec6174
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=latte-dock
pkgver=0.8.9
pkgver=0.9.2
pkgrel=0
arch="all !ppc64le !s390x" # Limited by libksysguard -> qt5-qtwebengine
url="https://store.kde.org/p/1169519/"
pkgdesc="A dock based on Plasma Frameworks"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends="kactivities"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev libksysguard-dev
kactivities-dev karchive-dev kcoreaddons-dev kguiaddons-dev kcrash-dev
kdbusaddons-dev kdeclarative-dev kglobalaccel-dev ki18n-dev kiconthemes-dev
knewstuff-dev knotifications-dev plasma-framework-dev kwayland-dev
kwindowsystem-dev kxmlgui-dev xcb-util-dev plasma-desktop-dev"
source="https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz
fix-build.patch"
source="https://download.kde.org/stable/latte-dock/latte-dock-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
......@@ -32,5 +32,4 @@ package() {
DESTDIR="$pkgdir" make install
}
sha512sums="4a542df07cfb760c4413eeefe65ebbc5405cc31f5de9039464e2390c84c60611e3a58d2458bf6750ea43e97959df68a75fa068c6b1fc5fdaf33f5b6745d08fd5 latte-dock-0.8.9.tar.xz
3b15da899f736e11ae136f47a4813a45a11d3ed74fb015653db50029a875cff884a30763333a6bf2fce077b08199be0330d8441e6628d66162baf4ab89a9dca5 fix-build.patch"
sha512sums="3537ec6b9503802a7efbbea7ae6ddf864188ba3b73c8121b434efc527f3c3e8d8f5e68447541a867b4422ccc5e3d2af85f491807a597bdb747960e8ab983bebd latte-dock-0.9.2.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment