From d5b08cc24bef5dfbbd16a2149c4e517db874be01 Mon Sep 17 00:00:00 2001
From: Leonardo Arena <rnalrd@gmail.com>
Date: Tue, 9 Jun 2009 06:25:43 +0000
Subject: [PATCH] testing/amavisd-new: post-install fixed

---
 testing/amavisd-new/APKBUILD     | 8 +++++++-
 testing/amavisd-new/common_vars  | 8 --------
 testing/amavisd-new/post-install | 7 ++++++-
 3 files changed, 13 insertions(+), 10 deletions(-)
 delete mode 100644 testing/amavisd-new/common_vars

diff --git a/testing/amavisd-new/APKBUILD b/testing/amavisd-new/APKBUILD
index 312edfb5ff9a..3b9562528e9f 100644
--- a/testing/amavisd-new/APKBUILD
+++ b/testing/amavisd-new/APKBUILD
@@ -17,7 +17,12 @@ source="http://www.ijs.si/software/amavisd/$pkgname-$pkgver.tar.gz"
 build() {
 	cd "$srcdir/$pkgname-$pkgver"
 
-	. ../../common_vars
+	HOME=/var/amavis
+	QUARANTINE=$HOME/quarantine
+	USER=amavis
+	GROUP=amavis
+	DIRS="$HOME $HOME/tmp $HOME/var $HOME/db $HOME/home $QUARANTINE"
+	CONFIG=/etc/amavisd.conf
 
 	for dir in $DIRS
 	do
@@ -36,3 +41,4 @@ build() {
 }
 
 md5sums="02b0bd38b40258841c60479603dc6842  amavisd-new-2.6.3.tar.gz"
+
diff --git a/testing/amavisd-new/common_vars b/testing/amavisd-new/common_vars
deleted file mode 100644
index cb52b4351aac..000000000000
--- a/testing/amavisd-new/common_vars
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-HOME=/var/amavis
-QUARANTINE=$HOME/quarantine
-USER=amavis
-GROUP=amavis
-DIRS="$HOME $HOME/tmp $HOME/var $HOME/db $HOME/home $QUARANTINE"
-CONFIG=/etc/amavisd.conf
diff --git a/testing/amavisd-new/post-install b/testing/amavisd-new/post-install
index 310ead353a17..56cad39f523e 100755
--- a/testing/amavisd-new/post-install
+++ b/testing/amavisd-new/post-install
@@ -1,6 +1,11 @@
 #!/bin/sh
 
-. ../../common_vars
+HOME=/var/amavis
+QUARANTINE=$HOME/quarantine
+USER=amavis
+GROUP=amavis
+DIRS="$HOME $HOME/tmp $HOME/var $HOME/db $HOME/home $QUARANTINE"
+CONFIG=/etc/amavisd.conf
 
 addgroup $USER
 adduser -h $HOME -s /bin/false -G $GROUP -D $USER
-- 
GitLab