Commit 300e04f0 authored by Natanael Copa's avatar Natanael Copa

main/expat: security upgrade to 2.2.7 (CVE-2018-20843)

fixes #10633
parent 901a6212
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=expat
pkgver=2.2.5
pkgver=2.2.7
pkgrel=0
pkgdesc="An XML Parser library written in C"
url="http://www.libexpat.org/"
......@@ -12,8 +12,10 @@ subpackages="$pkgname-dev $pkgname-doc"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 2.2.7-r0:
# - CVE-2018-20843
# 2.2.0-r1:
# - CVE-2017-9233
# - CVE-2017-9233
build() {
cd "$builddir"
......@@ -35,4 +37,4 @@ package() {
make DESTDIR="$pkgdir/" install
}
sha512sums="8226970a7e5d2b8d7818081758ca59bb6ce2d655feaa9d3a92481629000b73fde4782f50343d58ec4e1cebe75649e1980f636775a731d8aa4b55ceb843d9f637 expat-2.2.5.tar.bz2"
sha512sums="a078692317b44f14a9acdca4ddc04adac6a48d22ab321bba3e9e32c92131752aa397915d7121c4a95dc1b603d6a6128f7dce3741093d4322944787e0b49b4c00 expat-2.2.7.tar.bz2"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment