Commit 1d0a09a1 authored by Milan P. Stanić's avatar Milan P. Stanić

community/crystal: upgrade to 0.30.0

use llvm8 to build
remove unneeded patches
disable on aarch64 till fixed, it fails to build properly
parent 4c42f56d
......@@ -2,13 +2,13 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=crystal
pkgver=0.29.0
pkgver=0.30.0
pkgrel=0
_bootver=0.28.0
_llvmver=5
_bootver=0.29.0
_llvmver=8
pkgdesc="The Crystal Programming Language"
url="https://crystal-lang.org/"
arch="x86_64 aarch64"
arch="x86_64" # disable aarch64 till fixed (upstream ?)
license="Apache-2.0"
depends="gc-dev libatomic_ops libevent-dev libevent-static gcc gmp-dev pcre-dev"
checkdepends="openssl-dev libxml2-dev readline-dev tzdata yaml-dev zlib-dev"
......@@ -22,8 +22,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
https://dev.alpinelinux.org/archive/crystal/crystal-$_bootver-aarch64-alpine-linux-musl.tar.gz
disable-specs-using-GB2312-encoding.patch
fix-spec-std-kernel-spec.cr.patch
fix-llmv5-version.patch
fix-cipher-check-in-openssl-socket-spec.patch
"
builddir="$srcdir/$pkgname-$pkgver"
......@@ -120,10 +118,8 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
sha512sums="690183878c1d4f8bea2be419238aae78b40fe06fbfef6b23a31162eab8edec726bd5f87b3e39dbb76d5c3b82dde5d0fcb79ed34474bf62d1ea17c0901ff63337 crystal-0.29.0.tar.gz
5251deae590d24f2e86c44763297a0a271832213b459a4f3b2e5f8a9f988deba55767f6fc3f65873fcfd849c715c7ecec3ce8d26dd3f845fa790acd809c71d4e crystal-0.28.0-x86_64-alpine-linux-musl.tar.gz
734774551eb19af3821b4394ecf10f9c9dc82a0b18936a795c2bcdd93d99f0c8b33c7c2c7e86d942c0794d7288207f6cf5f965521b4b428a953181519adf73c8 crystal-0.28.0-aarch64-alpine-linux-musl.tar.gz
sha512sums="9c3da09b8ed57d1fd6942350cefe3be7cf6f1ab32a86329c0eda24138e30f44b822161b8eb3bca057bd8e7b0a47fefbe566af1284f486643080a967c1cb79483 crystal-0.30.0.tar.gz
daf684e4d1bbcc92b2fa39cce40f4938e7fb8927349182941b1a2f5542266f1dcaa8401bb52376bd09a9499cccd2d291eaaad8360390efe23bcce90131ebe03d crystal-0.29.0-x86_64-alpine-linux-musl.tar.gz
0d92e7b50cfc931f70ba805a8ab775802cbe958908e84881c331adf81cbfe33664f11d3a722c0b98b6043f43d0e5a0f58c012145c7440fd34716c1b58972b9df crystal-0.29.0-aarch64-alpine-linux-musl.tar.gz
269976fbc990dde075769e651c9fac6e7e0b39681e55cbd067c6d2a790c58a096bdc9981f62ae69b5217623025ba768daa63bc5316bd8ddd18192d88839aedcb disable-specs-using-GB2312-encoding.patch
ee1d81b40a9b15b2abfecbc61a1ef830700cc5613f9d2626722e8393633ed5d40329ac1fc2813b08b66c689876d3bd8a9f949a22beeda572ea3d4753f58417a8 fix-spec-std-kernel-spec.cr.patch
9ea84621c4348e9ca746b043186b99b59dbbe7ef3530b5b51394c799debe1db5df20c06bc647e97741ae18010344bf10be2bb3db25071b03c04a066124ec00d4 fix-llmv5-version.patch
38657d9ebad8d778490adea1551f65c9ddd676d0d95aa7c203fb7f7d996af6cf25b5f3b939023effe700820e029a99ccc9c1ea685577c53c9526ffa5fdcd4c19 fix-cipher-check-in-openssl-socket-spec.patch"
ee1d81b40a9b15b2abfecbc61a1ef830700cc5613f9d2626722e8393633ed5d40329ac1fc2813b08b66c689876d3bd8a9f949a22beeda572ea3d4753f58417a8 fix-spec-std-kernel-spec.cr.patch"
diff --git a/spec/std/openssl/ssl/socket_spec.cr b/spec/std/openssl/ssl/socket_spec.cr
index 04e2162e7..5372a190c 100644
--- a/spec/std/openssl/ssl/socket_spec.cr
+++ b/spec/std/openssl/ssl/socket_spec.cr
@@ -15,7 +15,7 @@ describe OpenSSL::SSL::Socket do
end
client = server.accept
- client.cipher.should contain "RSA"
+ client.cipher.should eq "TLS_AES_256_GCM_SHA384"
client.close
end
end
--- a/src/llvm/lib_llvm.cr
+++ b/src/llvm/lib_llvm.cr
@@ -5,7 +5,7 @@
command -v llvm-config-6.0 || command -v llvm-config60 || \
(command -v llvm-config > /dev/null && (case "$(llvm-config --version)" in 6.0*) command -v llvm-config;; *) false;; esac)) || \
command -v llvm-config-5.0 || command -v llvm-config50 || \
- (command -v llvm-config > /dev/null && (case "$(llvm-config --version)" in 5.0*) command -v llvm-config;; *) false;; esac)) || \
+ (command -v llvm5-config > /dev/null && (case "$(llvm5-config --version)" in 5.0*) command -v llvm5-config;; *) false;; esac)) || \
command -v llvm-config-4.0 || command -v llvm-config40 || \
(command -v llvm-config > /dev/null && (case "$(llvm-config --version)" in 4.0*) command -v llvm-config;; *) false;; esac)) || \
command -v llvm-config-3.9 || command -v llvm-config39 || \
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment