From c0c37e8b26da2f5355b11fc770c380196b0df11f Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Fri, 18 Aug 2017 04:37:11 +0000
Subject: [PATCH] community/cpio: modernise, add test suite

---
 community/cpio/APKBUILD | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

diff --git a/community/cpio/APKBUILD b/community/cpio/APKBUILD
index 01406169de1d..16e698546125 100644
--- a/community/cpio/APKBUILD
+++ b/community/cpio/APKBUILD
@@ -2,12 +2,12 @@
 # Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
 pkgname=cpio
 pkgver=2.12
-pkgrel=1
+pkgrel=2
 pkgdesc="A tool to copy files into or out of a cpio or tar archive"
 url="http://www.gnu.org/software/cpio"
 arch="all"
 license="GPL"
-depends="tar"
+depends=""
 subpackages="$pkgname-doc"
 source="$pkgname-$pkgver.tar.bz2::http://ftp.snt.utwente.nl/pub/software/gnu/cpio/$pkgname-$pkgver.tar.bz2"
 
@@ -22,9 +22,14 @@ build() {
 	make
 }
 
+check() {
+	cd "$builddir"
+	make check
+}
+
 package() {
 	cd "$builddir"
-	make DESTDIR="$pkgdir" install || return 1
+	make DESTDIR="$pkgdir" install
 	rm -f "$pkgdir"/usr/lib/charset.alias
 	rm -f "$pkgdir"/usr/libexec/rmt # part of the tar pkg
 	rm "$pkgdir"/usr/share/man/*/rmt.*
-- 
GitLab