diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 34b70f40a9baa947c78683b23466bcdea8ca88a7..200489794a1652cb489eca7fcf27f934d0567b13 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -62,7 +62,7 @@ mips)   export GOARCH="mips" GOMIPS=softfloat ;;
 mips64) export GOARCH="mips64" GOMIPS64=softfloat ;;
 mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;;
 mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;;
-*)      die "Unsupported arch" ;;
+*)      export GOARCH="unsupported";;
 esac
 
 builddir="$srcdir"/go