diff --git a/community/exfat-utils/APKBUILD b/community/exfat-utils/APKBUILD
index 6d764cc051c06176fd35bd5348454f2b81742c65..7169d4d430d866987d0e0933c4b985fe6666b398 100644
--- a/community/exfat-utils/APKBUILD
+++ b/community/exfat-utils/APKBUILD
@@ -1,40 +1,24 @@
-# Maintainer:
+# Maintainer: TBK <alpine@jjtc.eu>
 pkgname=exfat-utils
 pkgver=1.3.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Utilities for exFAT file system"
 url="https://github.com/relan/exfat"
 arch="all"
-license="GPL-2.0+"
-depends=""
-makedepends=""
-install=""
+license="GPL-2.0-or-later"
+options="!check" # no test suite
 subpackages="$pkgname-doc"
-source="https://github.com/relan/exfat/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+source="https://github.com/relan/exfat/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
 
 build() {
-	cd "$builddir"
-
 	./configure \
 		--prefix=/usr \
-		--sbindir=/usr/bin
-	make CCFLAGS="${CFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
-}
-
-check() {
-	cd "$builddir"
-	make check
+		--sbindir=/usr/sbin
+	make
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
-
-	# Install man pages
-	install -Dm444 dump/dumpexfat.8 "${pkgdir}/usr/share/man/man8/dumpexfat.8"
-	install -m444 fsck/exfatfsck.8 "${pkgdir}/usr/share/man/man8"
-	install -m444 mkfs/mkexfatfs.8 "${pkgdir}/usr/share/man/man8"
-	install -m444 label/exfatlabel.8 "${pkgdir}/usr/share/man/man8"
 }
 
 sha512sums="e1c5b708f22e878d7521e3299866bba127145757e3620696ff11b18c8c7d4830522974e8ee4771234b70aa9718295d3433779cf34ca990e28ccc06cbf9325f7e  exfat-utils-1.3.0.tar.gz"