diff --git a/testing/py-dulwich/APKBUILD b/testing/py-dulwich/APKBUILD
index 98c8648de50b6b9f1dc3714fdf077c8f9d80fe69..b71b432162fe059a84ea17f90560cb81e0e7ed98 100644
--- a/testing/py-dulwich/APKBUILD
+++ b/testing/py-dulwich/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
 pkgname=py-dulwich
 _pkgname=dulwich
-pkgver=0.19.9
+pkgver=0.19.10
 pkgrel=0
 pkgdesc="A python implementation of the Git file formats and protocols"
 url="https://www.dulwich.io"
@@ -11,8 +11,8 @@ license="GPL-2.0-or-later or Apache-2.0"
 options="!check" # Tests are failing (http-backend)
 makedepends="python2-dev python3-dev py-setuptools"
 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://www.dulwich.io/releases/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-dulwich-$pkgver
 
 build() {
 	cd "$builddir"
@@ -48,4 +48,4 @@ _py() {
 	$python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
 }
 
-sha512sums="7e97faaf566c60886ae806941c5d58495fd0fd3e7fe6d7d23033c6b721bd602ed6dce429c13d50fca6da320984a9a352edb7709c59cdea98c28ccd5522817580  dulwich-0.19.9.tar.gz"
+sha512sums="0699e7cdea103f2caca24b7841d2cb761d264d3847c22ceb74b5c3f9a890ad8143dad5affd339da424b38c1b13e55788b2d521797b9653a7ff7c373ab02b2401  dulwich-0.19.10.tar.gz"