diff --git a/community/cloc/APKBUILD b/community/cloc/APKBUILD
index bfd9845dd684e12832a5c82ec3ae30b9c53bcba1..4abed10dacd90ca20da55c5eac0e66afe36c779b 100644
--- a/community/cloc/APKBUILD
+++ b/community/cloc/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 # Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 pkgname=cloc
-pkgver=1.78
+pkgver=1.80
 pkgrel=0
 pkgdesc="Count lines of code"
 url="https://github.com/AlDanial/cloc"
@@ -11,8 +11,8 @@ depends="perl perl-algorithm-diff perl-regexp-common
 	perl-parallel-forkmanager"
 makedepends=""
 subpackages="$pkgname-doc"
-source="https://github.com/AlDanial/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
-	disable-01_opts.patch"
+source="https://github.com/AlDanial/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+	disable-git-tests.patch"
 builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
@@ -32,5 +32,5 @@ package() {
 		"$pkgdir"/usr/share/doc/$pkgname/
 }
 
-sha512sums="e5824d0a0796302173974e516848abdb4e653c1df4d660bf60b51e766ad09239b8b72276e2cb6b57771399dadfd1c7eb60218dc62b80cebdeebf607150baeb35  cloc-1.78.tar.gz
-10039c23d06f16f3c44427ee0f0e5d16dd05d2c5364145f57c1e5de94227387907f9ecebe7d42fc976599a8c1814e51d5f0a4eddef154222c5138cbcce777c4a  disable-01_opts.patch"
+sha512sums="3f41a0e2bd4becbb393e24834c45d9998217443d5c6d0478be5ce4f9506bb8dcb44088ce4a2c75c06cb6af47b4432f3dc58db9009f9a350a00dd80802109117f  cloc-1.80.tar.gz
+57c645db88bd83a06c32a38311b5f5a8cb0b86af454f20c7f4ce4311cc87932f8a61de381d5ca9f7189271034b487f2cb35f1d8568674f772d2969fb2e4e9cac  disable-git-tests.patch"
diff --git a/community/cloc/disable-01_opts.patch b/community/cloc/disable-01_opts.patch
deleted file mode 100644
index 4f4303627e62fad033cea4f63d8acb56cc5fe4f2..0000000000000000000000000000000000000000
--- a/community/cloc/disable-01_opts.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-This part of the test suite currently fails, we therefore temporarily
-disable it until we figured out what's causing the failure.
-
-diff -upr cloc-1.76.orig/Unix/Makefile cloc-1.76/Unix/Makefile
---- cloc-1.76.orig/Unix/Makefile	2018-02-10 17:51:48.335889390 +0100
-+++ cloc-1.76/Unix/Makefile	2018-02-10 17:52:02.309227510 +0100
-@@ -95,7 +95,6 @@ test-pod:
- # Rule: test-code - Check that the counter works
- test-code:
- 	t/00_C.t
--	t/01_opts.t
- 
- # Rule: test - Run tests
- test: test-perl test-pod test-code
diff --git a/community/cloc/disable-git-tests.patch b/community/cloc/disable-git-tests.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b41f12a3849ef5b56e7ba150c5ae22100a756e45
--- /dev/null
+++ b/community/cloc/disable-git-tests.patch
@@ -0,0 +1,15 @@
+Disable all git-related tests. Those probably fail because the source
+tarball doesn't ship the `.git` directory. Needs further investigation.
+
+diff -upr cloc-1.80.orig/Unix/Makefile cloc-1.80/Unix/Makefile
+--- cloc-1.80.orig/Unix/Makefile	2018-10-06 18:14:59.066930304 +0200
++++ cloc-1.80/Unix/Makefile	2018-10-06 18:15:06.760329821 +0200
+@@ -95,8 +95,6 @@ test-pod:
+ # Rule: test-code - Check that the counter works
+ test-code:
+ 	t/00_C.t
+-	t/02_git.t
+-	t/01_opts.t
+ 
+ # Rule: test - Run tests
+ test: test-perl test-pod test-code