From 5cd2fb2f467468808d2dc984545dc0a9cddac8a8 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 21 Jan 2019 19:37:12 +0000
Subject: [PATCH] Revert "community/geth: fix build on ppc64le"

This reverts commit d348141fc830b82477b6eec6741e21f54514ceb2.
---
 community/geth/APKBUILD                 | 6 ++++--
 community/geth/fix-ppc64le-isatty.patch | 9 +++++++++
 2 files changed, 13 insertions(+), 2 deletions(-)
 create mode 100644 community/geth/fix-ppc64le-isatty.patch

diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index c41f706025c3..e4bd202ce3bc 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -10,7 +10,8 @@ license="LGPL-3.0"
 makedepends="go linux-headers"
 checkdepends="fuse"
 options="!check"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz
+	fix-ppc64le-isatty.patch"
 builddir="$srcdir/go-ethereum-$pkgver"
 
 build() {
@@ -29,4 +30,5 @@ package() {
 	install -m755 -t "${pkgdir}"/usr/bin build/bin/*
 }
 
-sha512sums="807acab8a61fd2708c88a1ab69b2f0a961b9dd4fec55edbb7329d1c358619d4f3e4137319c5231a8cf07ecb10f29506d6e7a8120e0c67e760dedc46171bb31fb  geth-1.8.21.tar.gz"
+sha512sums="807acab8a61fd2708c88a1ab69b2f0a961b9dd4fec55edbb7329d1c358619d4f3e4137319c5231a8cf07ecb10f29506d6e7a8120e0c67e760dedc46171bb31fb  geth-1.8.21.tar.gz
+7f1d4cf22e1d48baebd28725ee099cb878028980af336b6e92d1f580a24a7d11e8b302e2b1f8c14f5b18b1d01313abe43464d8bef631ca18e5b0d613fe0a10a0  fix-ppc64le-isatty.patch"
diff --git a/community/geth/fix-ppc64le-isatty.patch b/community/geth/fix-ppc64le-isatty.patch
new file mode 100644
index 000000000000..24b90b200e5a
--- /dev/null
+++ b/community/geth/fix-ppc64le-isatty.patch
@@ -0,0 +1,9 @@
+--- a/vendor/github.com/mattn/go-isatty/isatty_linux.go
++++ b/vendor/github.com/mattn/go-isatty/isatty_linux.go
+@@ -1,5 +1,5 @@
+ // +build linux
+-// +build !appengine,!ppc64,!ppc64le
++// +build !appengine
+ 
+ package isatty
+ 
-- 
GitLab