From 3044ea9937653d41ea57efa56b2d43a358ef7c9c Mon Sep 17 00:00:00 2001
From: Shiz <hi@shiz.me>
Date: Thu, 18 May 2017 03:18:47 +0200
Subject: [PATCH] testing/libc++: fix libc++abi tests

---
 testing/libc++/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/libc++/APKBUILD b/testing/libc++/APKBUILD
index c867dd01b582..3a73d02c62ba 100644
--- a/testing/libc++/APKBUILD
+++ b/testing/libc++/APKBUILD
@@ -26,7 +26,7 @@ builddir="$srcdir"
 _cxxdir="$srcdir/libcxx-$pkgver.src"
 _abidir="$srcdir/libcxxabi-$pkgver.src"
 
-# Tests on armhf are too slooow on armhf, disable them for now.
+# Tests on armhf are too slooow, disable them for now.
 case "$CARCH" in
 	armhf) options="!check";;
 esac
@@ -56,6 +56,7 @@ build() {
 		-DLIBCXXABI_USE_LLVM_UNWINDER=ON \
 		-DLIBCXXABI_LIBUNWIND_INCLUDES=/usr/include \
 		-DLIBCXXABI_LIBCXX_INCLUDES="$_cxxdir"/include \
+		-DLIBCXXABI_LIBCXX_LIBRARY_PATH="$_cxxdir"/build/lib \
 		-DLIBCXXABI_INCLUDE_TESTS=1
 	make
 
@@ -79,8 +80,7 @@ build() {
 
 check() {
 	cd "$_abidir"/build
-	# FIXME!
-	make check-cxxabi || true
+	make check-cxxabi
 
 	cd "$_cxxdir"/build
 	# XXX: Some tests fail due to fakeroot currently, and some other due
-- 
GitLab