diff --git a/testing/libc++/APKBUILD b/testing/libc++/APKBUILD
index c867dd01b5821316fd19fe451ba7344c05f6bb3a..3a73d02c62bab26d4cd44793ee12d257fc895bfd 100644
--- a/testing/libc++/APKBUILD
+++ b/testing/libc++/APKBUILD
@@ -26,7 +26,7 @@ builddir="$srcdir"
 _cxxdir="$srcdir/libcxx-$pkgver.src"
 _abidir="$srcdir/libcxxabi-$pkgver.src"
 
-# Tests on armhf are too slooow on armhf, disable them for now.
+# Tests on armhf are too slooow, disable them for now.
 case "$CARCH" in
 	armhf) options="!check";;
 esac
@@ -56,6 +56,7 @@ build() {
 		-DLIBCXXABI_USE_LLVM_UNWINDER=ON \
 		-DLIBCXXABI_LIBUNWIND_INCLUDES=/usr/include \
 		-DLIBCXXABI_LIBCXX_INCLUDES="$_cxxdir"/include \
+		-DLIBCXXABI_LIBCXX_LIBRARY_PATH="$_cxxdir"/build/lib \
 		-DLIBCXXABI_INCLUDE_TESTS=1
 	make
 
@@ -79,8 +80,7 @@ build() {
 
 check() {
 	cd "$_abidir"/build
-	# FIXME!
-	make check-cxxabi || true
+	make check-cxxabi
 
 	cd "$_cxxdir"/build
 	# XXX: Some tests fail due to fakeroot currently, and some other due